Can't install Android plugin


Can’t install the Android plugin from the plugins page using the latest jme3.1 beta snapshot

I get this:

Some plugins require plugin Common Test Runner API to be installed.
The plugin Common Test Runner API is requested in version >= 1.19.1 (release version 1) but only 2.8.1 (of release version different from 1) was found. The following plugin is affected: Android

Any ideas please?

Does Android work in 3.1 beta?


Ok, I just found out that I don’t need the plugin for it to work. I got the basic game app working.

I tried doing the exact same with the testApp but I get this in the output:

ant -f C:\Users\Ghost\Documents\Workspace\JmeTests run-android
Target “run-android” does not exist in the project “JmeTests”.
BUILD FAILED (total time: 0 seconds)

And I don’t get an .APK file in the dist.

I’m not sure, but I think you firstly need to download the Android SDK, then enable android deployment in your project properties. Then, right click in your project then select Set Configuration > Android.

I can’t tell you exactly, but that’s what I did a long time ago.

Eric_Bourque, you should only need to set in Tools → Plagins → Settings → NBAndroid Update → URL


Thank you so much, that worked perfectly!