Can't open Vehicle Creator

Hi.
I can’t open Vehicle Creator, when I try to, the IDE just closes.
Running v3.2.1-stable-sdk3.

Tagging @Darkchaos

Did you follow these instructions?

https://wiki.jmonkeyengine.org/sdk/vehicle_creator.html

I can’t even do the step 1. When I right-click and select “Edit Vehicle”, JME window closes.
I’ll give up and try to make the vehicle control work by hand again.
Thanks for the answers.

Yes, doesn’t even throw an exception, just kills the SDK.

I tried to reconstruct the fault and it leads to this:

     [exec] Bullet-Native: Initializing java classes
     [exec] #
     [exec] # A fatal error has been detected by the Java Runtime Environment:
     [exec] #
     [exec] #  SIGSEGV (0xb) at pc=0x00007fd2eeb94a34, pid=22791, tid=0x00007fd3048e4700
     [exec] #
     [exec] # JRE version: Java(TM) SE Runtime Environment (8.0_171-b11) (build 1.8.0_171-b11)
     [exec] # Java VM: Java HotSpot(TM) 64-Bit Server VM (25.171-b11 mixed mode linux-amd64 compressed oops)
     [exec] # Problematic frame:
     [exec] # C  [libbulletjme.so+0xf9a34]  btStridingMeshInterface::InternalProcessAllTriangles(btInternalTriangleIndexCallback*, btVector3 const&, btVector3 const&) const+0x244
     [exec] #
     [exec] # Failed to write core dump. Core dumps have been disabled. To enable core dumping, try "ulimit -c unlimited" before starting Java again
     [exec] #
     [exec] # An error report file with more information is saved as:
     [exec] # /home/.../hs_err_pid22791.log
     [exec] #
     [exec] # If you would like to submit a bug report, please visit:
     [exec] #   http://bugreport.java.com/bugreport/crash.jsp
     [exec] # The crash happened outside the Java Virtual Machine in native code.
     [exec] # See problematic frame for where to report the bug.
     [exec] #

So I am not sure what has changed or why no-one else has that problem?

1 Like

Why not try with older versions of JME, so that the bug can be found and anybody benefit from your bug report, not to mention that you get to use the tool you want to use?

Im on 3.1 stable so that would be 3.0.

Could be something changed that is not even related to vehicle creator so like how would you even know where to start?

Wrong: the development of 3.1 has been long and there was many prerelease. You might try this, for example https://github.com/jMonkeyEngine/jmonkeyengine/releases/tag/v3.1.0-alpha4

Because I’m tired of pulling my hair while reading, searching solutions and fixing examples.
I didn’t thought that it could help other people. I’ll try other versions.

This is only half of my point. There is already a solution for your problem, it just need some fix… it’s probably better to fix it rather than roll out your own.

Even if it were utter thrash, you would still learn from the mistake of others…

I think when he says “by hand” he means just creating the control and setting it up in code.

…which to me is a fine idea and likely where he’d have ended up anyway… even if the SDK worked for this. There are half a dozen good reasons to do this in code once you know the setup you want. No harm in hand tweaking to get there, too.

Yep, that’s what I meant.

Well, I’ve tested from version 3.2.1-stable-sdk3 to jMonkeyEngine SDK 3.1.0 Stable, (for 64 bits Windows, running them as admin), and I couldn’t open the vehicle control editor…
I could finally get how to implement the VehicleControl by code, so if I’m the only one having this issue, don’t waste your time.

Thanks for your answers, and sorry for the late answer, I tried to test the versions as fast as I could.

1 Like