Can't run jMonkey in ubuntu 10.04 and eclipse 3.5 galileo

I'm facing a very weird problem trying to run jMonkey 2 tests in ubuntu 10.04.

I did try every known possibility.

When I run a test (I've tried several of them) the window opens and closes before I can see anything. No error is shown.

I don't think this is about the native libraries, I've configured them. (lwjgl.jar native library is pointing to the correct folder and also swt.jar is the correct one).

I made the same setup in windows (with the appropriate libs, of course) and it runs OK.

Things I've tried:

  • Run with jogl. Same result.
  • Updating lwjgl from the lwjgl site. Same result.
  • Run with jMonkey 3. Same result.
  • Run with VM arguments -Djava.library.path=lib/lwjgl/native/linux. Same result.
  • Debugging lwjgl source. Found that the execution flow stops inside a native function, but no error is thrown.
  • Run lwjgl examples. It runs OK. (It means opengl is proper configured)

    Is anyone running jME in ubuntu 10.04 with eclipse galileo with no problem?

    I don't know what else to try…any help would be very appreciated.

Yes, I use SVN to get jme2. I'm gonna take a look on the graphics driver…

Thanks by the quick reply.


I use ubuntu 10.4 and eclipse 3.5 like you and both jme2 and 3 work well

where did you get jme2 ?

svn ?

what about your graphics driver in ubuntu ?

which mark is your graphics card then ?


try this code in your terminal

inxi -F

if you see Direct Rendering Yes

then your card is ok

I suggest you to download jme2 again with this tut (got from signature of core-dump ^^ )

normally I download nightly build and I'm very happy with it (but it just doesnt have the tests you need)

if you want you can also try download nightly build, then copy the code of tests and let them run (a lot of effort ^^)

It works now!  :smiley:

The problem was the graphics driver.

My card is an Nvidia, I've installed the package nvidia-current through synaptic and that did the trick.

Thanks, dude!

you are welcome

to the hell  :evil:

:smiley: just kidding, nice to know that it worked for you ^^