Can't start a demo in IntelliJ Idea

Hello all.



I'm trying to get jME back onto my system after a long break in development, but am having trouble getting the demos to load.  When I attempt to run a demo from IntelliJ IDEA I get the following error:


Jul 10, 2005 8:32:37 PM com.jme.app.BaseGame start
INFO: Application started.
Jul 10, 2005 8:32:37 PM com.jme.system.PropertiesIO <init>
INFO: PropertiesIO created
Jul 10, 2005 8:32:37 PM com.jme.system.PropertiesIO load
WARNING: Could not load properties: java.io.FileNotFoundException: properties.cfg (The system cannot find the file specified)
java.lang.UnsatisfiedLinkError: no lwjgl in java.library.path
   at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1682)
   at java.lang.Runtime.loadLibrary0(Runtime.java:822)
   at java.lang.System.loadLibrary(System.java:992)
   at org.lwjgl.Sys.<clinit>(Sys.java:64)
   at org.lwjgl.opengl.Display.<clinit>(Display.java:96)
   at com.jme.system.lwjgl.LWJGLPropertiesDialog.<init>(LWJGLPropertiesDialog.java:148)
   at com.jme.app.AbstractGame.getAttributes(AbstractGame.java:180)
   at com.jme.app.BaseGame.start(BaseGame.java:57)
   at jmetest.effects.TestDynamicSmoker.main(TestDynamicSmoker.java:72)
   at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
   at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
   at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
   at java.lang.reflect.Method.invoke(Method.java:585)
   at com.intellij.rt.execution.application.AppMain.main(AppMain.java:78)
Jul 10, 2005 8:32:38 PM com.jme.app.SimpleGame cleanup
INFO: Cleaning up resources.
Jul 10, 2005 8:32:38 PM com.jme.input.InputSystem getKeyInput
WARNING: KeyInput is null, insure that a call to createInputSystem was made before getting the devices.
Jul 10, 2005 8:32:38 PM com.jme.input.InputSystem getMouseInput
WARNING: MouseInput is null, insure that a call to createInputSystem was made before getting the devices.
Jul 10, 2005 8:32:38 PM com.jme.app.BaseGame start
INFO: Application ending.



Back when I first downloaded jME there was an IntelliJ IDEA tutorial for getting the CVS and linking everything up (it is even still referenced in the forums), but I can't find it anywhere on the main site.  If it is still there, can someone point it to me?  I'm guessing my project is expecting things to be in my project directory, but they are really in the local cvs root... or something.  It's been a really long time since I loaded IDEA. :)

Thanks for any help.

It seem to canot find the native libs ( lwjgl.dll / liblwjgl.so whatever) in you case.

You have to setup a -Djava.library.path="C:xxxxxx"  somewhere in you IDE to point to the native libs or put them

in a default place



hth

Martin

Thanks - I had put the lib reference in the wrong place. :slight_smile: