Check acceleration type


I have just realized that my JME does not use Hardware Acceleration on my setup ( My Nvidia GPU-Activity monitor says “No activity” though I am running my applications… ) I have previously added javaw.exe to “Force Hardware Acceleration” in the Nvidia control panel, but this does not seem to affect my JME apps ( while it directly affects a game such as MineCraft ).

Does any one have a hint as to how I enable hardware acceleration for my apps?

Also is there an in-code method of listing the current ( or available ) graphics accelerators?

( I do have the latest drivers n such )



This is an operating system / driver feature, jME3 does not work at that level. You will have to find a setting in one of those windows/driver configuration panels I am afraid :confused:

You may need to add not just javaw but java as well (the command line version)

LWJGL which is the library we use to access OpenGL will automatically choose the context that provides hardware acceleration, it will refuse to use a software context unless a special flag is specified. What this means is that your driver behaves incorrectly, another reason might be that you have two GPUs and the other one is being chosen for jME3. So, you will need to provide some info about your graphics card setup for us to help you

1 Like

Thank you for the input, fast as always. :slight_smile:

I am not on the machine I was working on yesterday. It’s a laptop with a Nvidia GeForce 325m - no SLI.

I will try to force java to hardware acceleration too. Is there not a way of retrieving a simple string from lwjgl describing the graphics accelerator?


Also I believe I have had 3 different drivers installed for this card, and my memory of frame rates and shader support suggest that my machine has used software acceleration under each driver.

@nihal said:
Is there not a way of retrieving a simple string from lwjgl describing the graphics accelerator?

Sure there is. And JME by default dumps this to info log level when the app starts up. At least last time I checked.

Just an update.

Momoko_Fan, you were right, adding Java.exe to forced hardware acceleration did enable hardware acceleration for my apps, I should have tried that earlier I guess. :slight_smile:

I am a bit surprised through, I am now running hardware acceleration for sure, but my fps does not seem to have changed much.

Edit: Sorry, fps did increase, it was just capped at 60. I ran a more demanding app ( a solar system ) and it ran at 50fps rather than the 20 I get in software mode. I’m a happy happy happy happy monkey now! :slight_smile:

Cheers and ty for the help,