Class not found exception

Hello:

I’m getting java.lang.ClassNotFoundException:com.jme3.system.jogl.JoglDisplay error. I used to have this .java file: com.jme3.system.jogl.JoglDisplay.java but I deleted it and still get the same error.

I tried all these: I performed an uninstall and install of JMonkey and still get the error. I deleted the .jmonkey from the appdata folder. I deleted every file that possibly was holding any sort of project settings and still get the same error. I start a new game file with no import calls in its .java file. I delete the JMonkeyEngine under the programs folder. All of this with no success.

As it stands right now, I can not do anything with JMonkey. Pretty funny right!

Please tell me if I need to delete something in my computer or something.

Any ideas on how to solve this?

This should make the SDK reset its values:

AppSettings settings = new AppSettings(true);
settings.setRenderer(AppSettings.LWJGL_OPENGL3);
Kartex app = new Kartex();
app.setSettings(settings);
app.start();

after you do it once you can delete the code above, and then run it without any trouble.

More info. This is how I feel about this bug:

Imgur

Its not a bug, its a feature, namely the quite common “saved settings” one :wink: