Client not seeing server. Windows Firewall Question

java 8
jme 3.1
windows 8.1

I am Using the Spidermonkey library and it works when on the same computer. I can start the server and client and they work when on the same box.

I am now trying to connect a client box to the server and it just hangs and then Timesout (

NOTE: both boxes are on my home network

NOTE: On the client box I can ping the server from a command prompt and it connects

NOTE: I setup a Tomcat server on the server box and my client can connect to that.

NOTE: I am using VM args to fill in address : ports -Dserver.address=“” -Dserver.port=“5110” and a sout spits the values out correctly when the client starts so I think it is has the right server ip and port.

NOTE: I believe I am only using TCP

Question: Do I need to set a windows firewall rule. If so which way and which box?
I tried setting Inbound TCP on the Client for port 5110 and outbound TCP on the server… but still no luck

Thanks for any help.

Second Question
Windows 8.1 java 8
What is wrong with this cmd statement.

java -cp “DinoWorld.jar;lib/*” -Dserver.address=“” -Dserver.port=“5110” chapter07.fps.client.FPSClient

I get Exception in thread “main” com.jme3.asset.AssetNotFoundException
at com.jme3.system.JmeDesktopSystem.showSettingsDialog(JmeDesktopSystem.
at com.jme3.system.JmeSystem.showSettingsDialog(

NOTE: There is an assets.jar file in the lib folder

…probably isn’t working like you want.

If the DinoWorld.jar was built with the JME SDK then you don’t need that as it will have embedded a relative classpath into the jar for all of the libs.

As to your other, see if you can connect to the port from the client machine. I don’t know if windows 8 still has a telnet command but that’s the easiest way. Telnet to the port and see if it connects or refuse the connection.

Impossible to tell without seeing your code. If you’ve done nothing special to avoid it then SpiderMonkey will automatically setup a UDP channel. Make sure your server’s firewall has the port open for UDP and TCP.

I havent figure out the firewall issue other then turning the server firewall off completely but I did figure out the class path.
Just in case anyone else needs it for windows.

In the SDK you can use tools/options : java button
Then you can click Always show output and set verbosity to verbose

It will spit out what the sdk uses to run your app in my case

java -cp "DinoWorld.jar;libs\jme3-jogg-3.1.0-alpha1.jar;libs\j-ogg-all-1.0.0.jar;libs\jme3-blender-3.1.0-alpha1.jar;libs\core-0.27.jar;libs\dense64-0.27.jar;libs\simple-0.27.jar;libs\denseC64-0.27.jar;libs\jme3-networking-3.1.0-alpha1.jar;libs\jme3-plugins-3.1.0-alpha1.jar;libs\jme3-core-3.1.0-alpha1.jar;libs\jme3-desktop-3.1.0-alpha1.jar;libs\jme3-lwjgl-3.1.0-alpha1.jar;libs\lwjgl-2.9.3.jar;libs\lwjgl-platform-2.9.3-natives-windows.jar;libs\lwjgl-platform-2.9.3-natives-linux.jar;libs\lwjgl-platform-2.9.3-natives-osx.jar;libs\jinput-2.0.5.jar;libs\jutils-1.0.0.jar;libs\jinput-platform-2.0.5-natives-linux.jar;libs\jinput-platform-2.0.5-natives-windows.jar;libs\jinput-platform-2.0.5-natives-osx.jar;libs\jme3-niftygui-3.1.0-alpha1.jar;libs\nifty-1.4.1.jar;libs\nifty-default-controls-1.4.1.jar;libs\nifty-style-black-1.4.1.jar;libs\xpp3-1.1.4c.jar;libs\eventbus-1.4.jar;libs\jsr305-2.0.2.jar;libs\jglfont-core-1.4.jar;libs\jme3-effects-3.1.0-alpha1.jar;libs\jme3-terrain-3.1.0-alpha1.jar;libs\jme3-jbullet-3.1.0-alpha1.jar;libs\jbullet.jar;libs\stack-alloc.jar;libs\vecmath-1.3.1.jar;libs\jme3-testdata.jar;libs\assets.jar;" -Dserver.address="" -Dserver.port="5110" chapter07.fps.client.FPSClient

So then what happens if you run just:

java -cp DinoWorld.jar -Dserver.address="" -Dserver.port="5110" chapter07.fps.client.FPSClient

If it’s the jar in the dist directory then it should already have all of those other jars in its embedded classpath. It’s always worked for me in the past.