Compaq presario

ok, it’s not working, i’m trying to run the demos on this machine as a development station. well suffice to say none of them work.



the gfx card is a:Trident cyberblade ia agp.

I can’t find alot of information about it, well nothing realy.

but I’ll look into it more when I’m on my home computer and can type without a the unfamiliarty of this keyboard.



Heres the error, comes up in both window and fullscreen.

8-May-2004 3:04:54 AM com.jme.app.BaseGame start

INFO: Application started.

8-May-2004 3:04:54 AM com.jme.system.PropertiesIO

INFO: PropertiesIO created

8-May-2004 3:04:54 AM com.jme.system.PropertiesIO load

INFO: Read properties

8-May-2004 3:05:30 AM com.jme.system.lwjgl.LWJGLDisplaySystem

INFO: LWJGL Display System created.

8-May-2004 3:05:31 AM com.jme.system.PropertiesIO save

INFO: Saved properties

8-May-2004 3:05:31 AM com.jme.system.lwjgl.LWJGLDisplaySystem

INFO: LWJGL Display System created.

8-May-2004 3:05:31 AM com.jme.system.lwjgl.LWJGLDisplaySystem initDisplay

SEVERE: Cannot create window

8-May-2004 3:05:31 AM com.jme.app.BaseGame start

INFO: Application ending.

This is a fairly serious error. Means LWJGL was unable to create a window with the settings you requested. Have you tried all the different settings?



If not, start with 640x480x16x60Hz.



If that doesn’t work, try downloading some of the LWJGL demos. See if they run.

Earlier

I’ve tried the createwindowtest. But I end up with 11 found display modes, and



org.lwjgl.LWJGLException: Mode not supported by hardware

at org.lwjgl.opengl.Window.nCreate(Native Method)

at org.lwjgl.opengl.Window.createWindow(Unknown Source)

at org.lwjgl.opengl.Window.create(Unknown Sourse)

at org.lwjgl.opengl.Window.main(Unknown Source)

Unable to create window!, exiting…



Here is the error. The display that i know the laptop can do is 800x600x16/32. it’s what this is running right now.

This laptop is somthing that i’m looking into buying a portable dev machine. so if it doesnt suit my needs i wont be getting it. I’ll try some more demos see if it works, can someone link a list of the lwjgl test’s.



TY JaydeRyu



1:23PST

Never mind all this. I just found a webpage that informs me that there is no OpenGL support for this graphics card.

ok it’s about 4:30am pst

I’m at work on a break. And its a coworkers laptop.



Ok i tried using Scitechs GLDirect 4.01 demo. And it does go a little farther

the window comes up some of the nodes are made, then everthing is dropped.



9-May-2004 4:23:04 AM com.jme.app.BaseGame start

INFO: Application started.

9-May-2004 4:23:04 AM com.jme.system.PropertiesIO

INFO: PropertiesIO created

9-May-2004 4:23:04 AM com.jme.system.PropertiesIO load

INFO: Read properties

9-May-2004 4:23:53 AM com.jme.system.lwjgl.LWJGLDisplaySystem



from the lwjgl

opengl.grass: UnsatisfiedLinkError nglGenProgramsNV

opengl.game: Failed due to stencil depth



I’m starting to think I should skip this laptop and look elsewhere. The graphics card is too old, and the Scitech doesnt make for lack of hardware.



INFO: LWJGL Display System created.

9-May-2004 4:23:57 AM com.jme.system.PropertiesIO save

INFO: Saved properties

9-May-2004 4:23:57 AM com.jme.system.lwjgl.LWJGLDisplaySystem

INFO: LWJGL Display System created.

9-May-2004 4:24:02 AM com.jme.renderer.lwjgl.LWJGLRenderer

INFO: LWJGLRenderer created. W: 640H: 480

9-May-2004 4:24:02 AM com.jme.renderer.AbstractCamera

INFO: Camera created.

9-May-2004 4:24:02 AM com.jme.util.lwjgl.LWJGLTimer

INFO: Timer resolution: 3579545 ticks per second

9-May-2004 4:24:02 AM com.jme.scene.Node

INFO: Node created.

9-May-2004 4:24:03 AM com.jme.scene.Node

INFO: Node created.

9-May-2004 4:24:03 AM com.jme.scene.Node attachChild

INFO: Child (FPS label) attached to this node (FPS node)

9-May-2004 4:24:08 AM com.jme.scene.Node attachChild

INFO: Child (Torus) attached to this node (rootNode)

9-May-2004 4:24:08 AM com.jme.scene.Node attachChild

INFO: Child (Background) attached to this node (rootNode)



I havent hit anykeys or moved the mouse. But it’s a work around to the problem. I would like to see the perfomance and see if it’s descent enough to consider. I won’t be getting hand on the laptop will next week so I won’t be able to check it out till then. But hey see how things go.



From some of the LWjgl errors i’m getting there seems to be a lack of stencildepth. The WindowCreationTest has garbage in the window, and a few other problems. so I think I’ll look elsewhere for a laptop but i know alittle more what to look for. TY

I had a problem similar problem with lwjgl 0.7 about 5/6 months ago & fixed it with the latest driver (driverguide.com).



I you haven’t done this I’ll really recommend registering with driverguide.com - it doesn’t cost anything & they don’t send you any email if you don’t want it. When I got my current machine it had no drivers at all with it & I have a fairly odd graphics card - I found everything I needed here to get it working.



Apologies if you have already done this.

No apologies needed, I thought it would solve the problem. But from what I found from the company, there is no OpenGL support for this gfx card. It’s not to bad though. It just means i’m not going to buy this particular laptop. I found that GLDirect was a good workaround, but I think the card itself has some things that have problems too.

from the lwjgl
opengl.grass: UnsatisfiedLinkError nglGenProgramsNV
opengl.game: Failed due to stencil depth

This error is perfectly ok, the Grass demo is nVidia only. I can't run it either. :)