Converting a blend file to j3o through JMP results in a bunch of empty nodes

I used blender 2.62 (which as far as I know is supported) to create a bunch of cubes and then try to convert. Resulting j3o file is just a bunch of empty nodes. Please see link http://imgur.com/a/jM33i.

I used the nightly build of JMP (September 12). Before I upgraded to nightly builds it would just throw an exception when trying to convert that file. Something about null material.

I found blender converter rather inconsistent. I would create the simplest mesh with uv mapped texture, and sometimes it would convert, other times it would just throw a bunch of exceptions. Really frustrating cause there isn’t much info about what the problem is. And after comparing two blend files, one that converts fine, and another that would cause a problem - I just can’t see the difference!

Also, when you place your files into JMP assets folder for conversion, where are you supposed to place texture file? In textures folder, or together with the model? Cause I tried both, and both worked on me on some files, both failed… Super frustrated.

Please help! So far I’m really in love with JME, just want the import pipeline to be seamless:)

https://wiki.jmonkeyengine.org/legacy/doku.php/jme3:external:blender

I swear the god, I followed that to the letter.

I would open blender, create a cube, uv unwrap it, apply a material with texture, then try to convert it in JMP and it would fail.

I will do the same thing from scratch and it will work! And worst part is I don’t know why!

And it wouldn’t read textures from the same folder all the time either…



I just wish it would say what the problem is, so that instead of redoing everything from scratch you can just fix it.

So you keep your images and models directly in the asset folder as outlined in the document linked on the top of that page?

Yes sir.

Sometimes I will try to convert a model and both the model and the texture will me in the assets/Models folder. It will fail. Then I will move the texture to assets/Textures, and it will work! Then another model I will put in assets/Models and texture in assets/Textures, and it won’t convert unless I putt the texture together with the model in the same folder…

I also have a model without any textures, just a material with colors. And it converts and works fine. I then created another one which is also a bunch of meshes with color-only material, and it’s all blank…

Well you can’t just move textures around… j3o as well as blend file mean a certain location for the image… But the thing is that the ogre exporter wants to copy the textures so you might end up linking those it exports to the models folder… Okay so best is probably to export the model to the textures folder, then move the j3o to “models” after converting it.

I do realize that you can’t just move textures around, but it would be nice to know where JMP is looking for a texture for a particular object, because sometimes it’s the same folder, others it’s different.

Also, is there a way to create subfolders in the assets/Textures folder and have JMP know to look in a specific subfolder?

Yes but as I said the problem is how the exporter works, it wants to copy the textures. If you’d import .blend files directly (which is in alpha state) then you could just edit the .blend in the models folder (or any subfolder) and keep the textures in the Textures folder (or subfolder) and use exactly those in both Blender and the SDK. So in this case its probably best to export the model elsewhere and then import it to the textures folder to keep the textures there… Or just export it to the textures folder (or sub) and convert it by double-clicking.

Ok, fair enough. How can I debug what’s wrong with conversion? For example, when the converted file simply has a spatial with nothing else in it?

And am I right to use blender 2.62? Is that the version that’s most reliable at the moment in terms of conversion?

I guess 2.62 still, with the SDK supplied exporter, yes. Lots of changes on the blender and ogre exporter front made it a bit hard to track all changes lately.

Should I submit use cases that cause problems?

Will getting nightly builds of JMP get me latest version of blender converter?

  1. No, working ones you can report though ^^
  2. Why do you want to know that?

Well, for every working case I have a one that doesn’t, so either way you’ll get to hear about it:)

I want to know that to make sure I use the latest available converter in hopes that it will resolve issues and I will finally be able to import models from blender smoothly… I just get really frustrated when there’s a problem with the blend file, and I feel like the fix is so simple… But no one will tell me what it is, and the converter just gives me a bunch of null pointer exceptions.

You can try the importer versions directly from their googlecode page. There is working configurations for all blender versions basically but some require workarounds (e.g. bmesh support etc).

I’ve been using blender 2.63 with nightly JME3 and every import I’ve tried has worked fine. (Although I don’t have massive numbers of different models I do have a few - and some moderately complex ones).

(Using direct import in the SDK .blend->.j3o)