Crash on low end system

It crashes on a native OpenGL method:

J  org.lwjgl.opengl.ARBBufferObject.nglBindBufferARB(IIJ)V

probably cause; bad OpenGL drivers.

It's a method related to VBOs, so try disableing all VBO.

Is there any way to quickly disable all VBOs?

With some hackery, yes… look inside LWJGLRenderer, ctrl-f for vbo. (I don't have the source before me right now)

Before using VBO jME queries the videocard driver to see if it supports VBO. Seems like the "Intel 915 GM/GMS, 910 GML chipset" might incorrectly report it does.

That seems to have fixed it. Is there any way to detect whether it would be more intelligent to disable VBO's, or should I just fix that via settings?

Alternatively you could update your graphics drivers  :wink:

That would be an excellent idea, if our client would be willing to allow us to do that as part of the installation procedure :slight_smile: Also, most corporate accounts don't have that kind of access :slight_smile:

And somehow I don't think Intel still supports the 815…

We don't have any workarounds for dealing with buggy cards/drivers like this. I suppose we should seriously consider accepting a patch that uses a -D system property to disable VBO (since I think all VBO checking is done in one method).

However you should be warned that with drivers as buggy as that it's probably not the last of your troubles…

We're not officially supporting it, but them being our lead customer, we're trying to accomodate as much as possible.

Just one comment:

I used to have a HP Pavillion laptop with the same setup: centrino 1.73 and Intel 915… Everything, execpt shader worked with JME. I even used it to test Dirty Racers:

Maybe it’s just a Driver problem.

Perhaps, but a driver update didn't help. Maybe it has something to with the fact that I'm using a LWJGLCanvas as the viewport. Nothing is wrong on the other systems that we've tested on.