Crash upon startup of simple application audio class missing

Upon starting up a baseline SimpleApplication, my process is halted with this error.

SEVERE: CRITICAL ERROR: Audio implementation class is missing!
Make sure jme3_lwjgl-oal or jm3_joal is on the classpath.
at java.base/jdk.internal.loader.BuiltinClassLoader.loadClass(
at java.base/jdk.internal.loader.ClassLoaders$AppClassLoader.loadClass(
at java.base/java.lang.ClassLoader.loadClass(
at java.base/java.lang.Class.forName0(Native Method)
at java.base/java.lang.Class.forName(
at com.jme3.system.JmeDesktopSystem.newObject(
at com.jme3.system.JmeDesktopSystem.newAudioRenderer(
at com.jme3.system.JmeSystem.newAudioRenderer(
at com.jme3.system.lwjgl.LwjglAbstractDisplay.initInThread(
at java.base/

My application has nothing in it’s constructor, and my main method is new MyGame().start();

I am using gradle to resolve my dependenies and my build.gradle looks like this

group ‘mcclean.jetpack’
version ‘1.0-SNAPSHOT’

apply plugin: ‘java’

def jme3 = [v: ‘3.2.1-stable’, g: ‘org.jmonkeyengine’]

repositories {

//JME Dependencies
dependencies {
compile “${jme3.g}:jme3-core:${jme3.v}”
runtime “${jme3.g}:jme3-desktop:${jme3.v}”
runtime “${jme3.g}:jme3-lwjgl:${jme3.v}”

dependencies {
testCompile group: ‘junit’, name: ‘junit’, version: ‘4.12’

What is causing this crash? I believe that my dependency setup is enough, as referenced here.

Edit: I’m using Intellij Community edition and macOS high sierra 10.13.3 if that helps.

Looks like the only difference between my sample application and yours is the runtime versus compile dependencies:

…you could try checking out that project and seeing if it runs.

Thanks, I’ve tried with both compile and runtime, but the error persists.

Perhaps your app settings are unusual. What is the value returned by



Did you try the example?

Yes I tried the example but unfortunately the same error persists.

I’ve done some more debugging and I’ve found the following strange error. If in the constructor of my class that extends simpla application I call the method setShowSettings(false); The error dissapears. I went into the debugger mode and I found that during the following method the value of the settings mapping AudioRenderer is LWJGL before the if(showSettings) block is executed. After the block is executed, but before the start method exits, the audio renderer setting becomes JOGL.

Here is the start method of SimpleApplication for convenience:

public void start() {
// set some default settings in-case
// settings dialog is not shown
boolean loadSettings = false;
if (settings == null) {
setSettings(new AppSettings(true));
loadSettings = true;

    // show settings dialog
    if (showSettings) {
        if (!JmeSystem.showSettingsDialog(settings, loadSettings)) {
    //re-setting settings they can have been merged from the registry.

Then you must be loading old cached settings with jogl set. Maybe you ran an untitled app settings with jogl set one time?

I think the app settings title is the preferences key used to retrieve the old values.

1 Like

Where does SimpleApplication cache it’s settings?

In the Java user preferences:

On Windows systems, preferences are stored in the Windows Registry. On Linux systems, they’re stored in the filesystem.

See also: