Culling Error? (Cylinder Mesh only partial visible)

Hey Guys.
What I did is basically this: I added an Cylinder-Mesh in Blender with the Fill-Type “Nothing”.
In Blender, everything looks fine, but even the SceneComposer is only showing the “outer faces”?

I already tried to set the CullingHint to Nothing/Never.

Here is a pic on how it looks. If I turn the cam, the thing which is now visible will become invisible.
Do you have a General Idea on what Kind of mesh I could use for that?
It’s a somewhat racing game and you race over wireframes. I tried “pipes” (cylinders) as well as planes, etc.
I guess I need some extruded geometry so I have two faces? (Inside and Outside?)

btw: That Auto-Correct of Discourse is capitalizing my Sentences :’(
Edit: Ignore that left part where some Vertices are missing. I am horrible at that :smiley:

I guess the issue is that the normals are pointing outwards. You could set them to point into the other direction in Blender if you don’t need to see the outside of the cylinder; I guess the cars are driving inside of it? Then you will never see the outside of it so just set the normals to face inside.
I think you can actually reproduce the issue in Blender when you set the shading to GLSL and Textured solid.

1 Like

That solved it. Thanks a lot!!
Here is a Little tutorial for the guys wondering on how to actually do it.
It also explains how to enable culling.

I am only uncertain on why disabling culling did not work :confused:

Another Question. Can you imagine why that pipes I just created are physically soaking me in? That’s not the case for any other geometry I recently created?

EDIT: Is it possible to “double” the normals to have two faces? (Because at the Moment you will Crash into obstacles you can only see from the inside :D)

At least on JME’s side, this has nothing to do with normal direction and nothing to do with object culling.

It has everything to do with face culling… which is a property of the material.

Perhaps flipping the normals in blender causes it to wind the triangles differently but whether a surface is drawn or not in JME has nothing to do with the direction of the normals. Only lighting is affected by normals.

Well I get the exact same issue when the normals are pointing outwards; once they point inwards, I’ve got the pipe I want:

normals outwards


normals inwards

I thought he just wanted to drive inside of the cylinder. Setting face culling to ‘off’ didn’t change anything for me. I guess the light that comes from the camera in the SceneComposer messes things up with the normals?

So what you probably want to do is leaving the normals as they are, going into edit mode; select all vertices, press e for extrude and press s for scale and type in 0.99. This will result in a slightly modified mesh which you can see from the inside and from the outside:

1 Like