Culling Failure with Mirror Modifier

Hey monkeys,

I ran into some culling problems when converting a model from .blend to .j3o.
I tested the issue a bit and found out that there may be an issue with the Mirror Modifier support in the Blender Importer.

All relevant data to the issue:

  • I have a .blend Model converted to .j3o
  • CullHint is set to ‘Dynamic’
  • When viewing the model in the sdk or ingame culling .does not work properly for one half.
  • When blender convertes the model into .obj it works.
  • When I apply the modifier before I convert the .blend to .j3o, everything works fine.

@Kaelthas , maybe you want to take a look at this?

Are you using 3.0 Release? Kaelthas knows about the mirror modifier problem, and I think may have fixed it already.

hehe, I just recently had a problem with BlenderImporter :slight_smile:
But no, this time I AM using the new 3.0 release for sure.

I had such problem before but even though I updated the model’s bounding box it did not help.
The mirrored part kept disappearing when it sholuldn’t.

But surprisingly when I changed the computer with different graphic card - it turned out to be working.

Could you upload your model you are using ?
Maybe I will finally find a solution.

As for applying the modifier - well everything will work in such case :wink:

@Kaelthas I sent you a private message with the link.

My graphics card is a mobile GTX660M if it helps you.

Good luck with fixing!