CVS help please!

i have had it with this stupid cvs!!

i followed the guide for setting it all up and i got ant aswell (who knows what they're for), when i try to login to cvs it keeps giving me "cvs exited normally with code 1". I signed up for and used that instead of guest but still nothing!

this is what i put in the cvsroot box: " login"

after i run that it comes up with the box asking for my password but when i put it in and press ok it exits and gives me that error.

itsss sooooooo annoying i just wanna do some java grrrrrrrrrr

I would recommend using an IDE, because from what you say I assume you are using cvs from command line!.

Check the two guides for setting up jME in Eclipse and NetBeans (pick the one IDE that appeals more to you… I use Eclipse, and used to use NetBeans)

yeh thing is i use blueJ, i hate eclipse because its soo over complicated and iv never used netbeans before, is there a way to do it through blueJ?

or better still is there a way to do it without cvs :slight_smile:

AFAIK, the nightly build works already, so you could download that, and you would not be terribly outdated!

Try these:

That should do it!

ok theres quite alot of jar files in there…which ones do i need to use?

in this first demo the imports are:


import com.jme.scene.shape.Box;

import com.jme.math.Vector3f;

which jar files are they in?

EDIT: oh i see the last one in the list is called jme.jar ha how did i miss it!

ok thanks for the help and speedy replies!

uhoh when i ran the demo (hello world)

it gave me a big error, most notably this line:

java.lang.NoClassDefFoundError: org/lwjgl/LWJGLException

somethings missing :frowning:

Most likely the lwjgl.jar file!

indeed but its not in that zip file i downloaded…

where do i get it?

hmmm i went to the lwjgl website and got all the necessary files there but now when i compile it says:

11-Nov-2007 22:52:47 start

INFO: Application started.

11-Nov-2007 22:52:47 com.jme.system.PropertiesIO <init>

INFO: PropertiesIO created

11-Nov-2007 22:52:47 com.jme.system.PropertiesIO load

WARNING: Could not load properties. Creating a new one.

11-Nov-2007 22:52:47 class HelloWorld start()

SEVERE: Exception in game loop

java.lang.UnsatisfiedLinkError: no lwjgl in java.library.path

at java.lang.ClassLoader.loadLibrary(

at java.lang.Runtime.loadLibrary0(

at java.lang.System.loadLibrary(

at org.lwjgl.Sys$

at Method)

at org.lwjgl.Sys.doLoadLibrary(

at org.lwjgl.Sys.loadLibrary(

at org.lwjgl.Sys.<clinit>(

at org.lwjgl.opengl.Display.<clinit>(

at com.jme.system.lwjgl.LWJGLPropertiesDialog.<init>(Unknown Source)

at Source)

at Source)

at HelloWorld.main(


at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

at sun.reflect.NativeMethodAccessorImpl.invoke(

at sun.reflect.DelegatingMethodAccessorImpl.invoke(

at java.lang.reflect.Method.invoke(

at bluej.runtime.ExecServer$

11-Nov-2007 22:52:47 cleanup

INFO: Cleaning up resources.

11-Nov-2007 22:52:47 com.jme.system.lwjgl.LWJGLDisplaySystem <init>

INFO: LWJGL Display System created.

11-Nov-2007 22:52:47 start

INFO: Application ending.

why is this sooo complicated :frowning:

It is complicated because you are not using an IDE!  :stuck_out_tongue:

This means that you forgot to set the -Djava.library.path=<path_to_lwjgl.dll> at the command line… Hope you don't mind this question, but are you relatively new to Java?

lol, ive been doing it a year now, but usually this stuff just works!

how do i do this command line stuff?

i dont seem to have a lwjgl.dll file…

ARRGGHH ok i found the lwjgl.dll file and put that in the classpath

now the error is much shorter and makes no sense whatsoever:

12-Nov-2007 18:53:05 start

INFO: Application started.

12-Nov-2007 18:53:05 com.jme.system.PropertiesIO <init>

INFO: PropertiesIO created

12-Nov-2007 18:53:05 com.jme.system.PropertiesIO load

WARNING: Could not load properties. Creating a new one.

any help?

That is not an error, that is just a warning that the configuration file was not found… The application will create its own after this, and continue execution.

ummm well nothing happened after that…

something aint right

Oh wait hold on, the window was hidden beneath everything else lol!