CVS unaccessible?

I just found jme and I have to say it looks very nice. :slight_smile:

Now I want to compile it, but the problem is that CVS seems to be down and the source zip of the nightly build has no build script included(why?).

I tried to register for an account at but the registration(!) is also unaccessible.

I failed to connect to the CVS via guest login with the build-in CVS of netbeans 5.0.

The tutorial for setting up netbeans is a little outdated

This is what I did to connect with nb 5.0:

CVS -> Checkout

CVS root: “”

password: none

and then the error: “Can not connect”

So is the root/password wrong or the CVS server down? :?

I also tried some webstart demos. Most work fine but the cloth demo is kind of strange: It shows me 800-900 fps(1024x768 fullscreen 32bit) but it is really very slow(roughly 5-15fps running on P4 3ghz).

Is this really so slow or just a problem with the timer? Does jme use the standard milliseconds timer or a high performance timer?

CVS is up, so it must be just the registration giving you problems. They turned off guest awhile back, so yes, the netbeans tutorial needs updating.

CVS is still working here (with Eclipse though), I tested with a "guest" account as well.

Yes, jME uses the millseconds timer, that is we use whatever LWJGL uses (apperently the hpref timer has issues on some systems). However, the webstarts are 0.9, and there were some improvements to the timer since then for very fast systems.

anonymous CVS is still working here (with Eclipse though)

interesting, I haven't been able to get anonymous working for a very long time, so I assumed they turned it off... I guess it's true what they say about assuming.

Registration on finally worked! :smiley: Downloading from cvs right now…

Sun was performing some maintenance to the their servers. There were notices around the site about it…  :wink:

Tried getting the latest src from cvs,  do i have something set incorrectly or does this look like cvs is down again?

cvs -d checkout -P jme



cvs checkout: cwd=C:jMonkeyDev ,current=C:jMonkeyDev

cvs server: cannot find module `jme

' - ignored

cvs [checkout aborted]: cannot expand modules

***** CVS exited normally with code 1 *****