Debug app "captures" mouse control

I’m running JMPlatform Alpha4 on Ubuntu Linux, Java 1.6.0_24.

Moving to JME from Java 3D. I have a test app which runs within a JFrame. When I run it in the debugger, it starts OK, displays the frame and the JmeCanvas within it as expected. But once I click the mouse within the JFrame/app, it is “captured” there so I cannot close the frame or even get back to the IDE or anything else on my desktop.



I then have to go to another machine, ssh in, and kill the java process of the program being debugged. Then I get my mouse control back and everything is normal.



I missed a turn somewhere…

turn off flycam, and turn on cursor when you are debugging that worked for me:



[java]

// Setting up scene

// Disable flying camera

flyCam.setDragToRotate(true);

flyCam.setEnabled(false);

[/java]

Why you run alpha btw?

I run into a similar thing on Windows XP; when I hit a debugging break point, the mouse is trapped within the screen space that my JME app was using & I can’t use it with anything outside of that boundary, even if a different app (in this case my IDE) is in focus. In my case, I found the following worked:

Alt-tab to the IDE

Alt-tab back to the JME app

Alt-tab to the IDE

Click within the IDE to establish focus

At this point my typically mouse works as expected, but sometimes it seems like I have to play around with the formula a bit. While my problem/solution may be Windows-centric, isn’t there some alt-tab key alternative you can use in Ubuntu?

1 Like