"Debugging" a corrupted scene file (j3o)

Ok, I fixed the AssetLinkNode, even scenes that would not load before should load fine now.

Ok. Thanks. I’m going to give it a shot again.

The AssetLinkNode seems to work correctly now.

I think there is still another bug, but I haven’t tried to reproduce it. Sometimes when you link an object it is in the SceneComposer window, but not in the SceneExplorer.

It’s really weird. I see 3 startinggates in the SceneComposer, but only 2 in the SceneExplorer. I have tried to fix it with restarting jMonkeyPlatform, but it’s still the same.

I think it only happens when you add an object for the first time to the SceneComposer.

Are you sure you haven’t attached it to some sub-node in your scenegraph?



I just linked the same j3o file 3 times.

I will test it a little bit further later this week.

It’s not a big problem for now. I only can’t remove the extra starting gate from the scene.

Hmm… I think you might have added the model to an existing link node, they can take more than one child asset, open the node to see the added child assets.