<del>Issues with Scene Explorer</del>

Hi everybody,

I’m new to jMonkey and am having some issues getting the basic scene editing feature to work. I am making a new scene and it pops up with the root node in the screen. But when I open Scene Explorer, there’s only a blank window (see the picture). I’ve tried re-installing the SDK but I’m having little luck. Anybody have any suggestions? Thanks

Try right clicking /assets/scenes in the JMonkeyPlatform and choosing ‘new Scene’ or whatever it says, then right click that and choose edit in scene composer. That should work methinks!


Well an empty scene is an empty scene… Turn on the light and put some stuff to see anything…

Thanks for the input lolliver, but I think I got that far, I’m having trouble after that part.

This might be some more of my noobieness showing through, but all of the tutorials I’ve watched show the root node in the Scene Explorer and then you add to the scene by attaching lights, spatials, and nodes to that through the explorer (which is where I’m running into trouble since there is no root node showing the explorer). Am I missing another way to do that?

Thanks again

Morning Plonex,

No problem, I wasn’t trying to patronize you I just didn’t know what you’d tried! :slight_smile:

So, the exact flowchart that I used (I actually closed the sceneexplorer window just to try this!)

Make sure that the scene explorer window is in sight (‘window’ on the top bar → SceneExplorer)

right click scenes → new empty jm3 scene → double click the new scene → A root node should be visible at the top.

Barring all of the above it might be time to reinstall the JMonkeyPlatform in case something has derped.


Ah, it’s working now! Thanks for all the help Lloliver. (and Normen).

What did you do else?

haha it turns out I just opened the Scene Explorer after a selecting a new scene. But after opening the scene explorer I needed to double click the scene to get it to open in the explorer. Seems silly now.

Yes! Patronising step by step approach ftw! :smiley:

ahem glad it’s working Plonex.