Detecting and disabling sound

Hi all,

I’m having some trouble running jME under machines that have no audio drivers installed. These are lab machines and audio is disabled by default unless speakers or headphones are plugged in. jME would crash during initialization unless I plug in a set of headphones.

I noticed that in the settings class, I can set the audio renderer to null to disable audio, which I believe would work. However, how do I test the presence/absence of openal drivers?


Actually I did add specific checks for that in the audio renderer. Can you please post the exception & stack trace?

Yeah I noticed in the audiorenderer that you checked and disable audio when it is not available. There is no exceptions or stack trace either, just a crash in Windows with a “Program not responding” error.

I’ll investigate some more and see if I can track down any specific error messages.

Thanks for looking into it!

Sounds like an issue either in OpenAL or in the configuration of the audio drivers. Maybe its trying to use a modem audio device or similar.