Early Blender Import Issues

Hi guys,

Having spent a while working on my Blender modelling skills (which are still crap, but at least I have some idea now!) I thought I’d try my first import into JMP. It has not started well !

I tried loading up an Asset Pack and importing my model. The good(ish) news is that I see an untextured version of my house in the preview screen:

Import Preview

So I click “Next” and then select the default “Create DTO” option. But then… Nothing. The scene viewer (or is it explorer, what’s the difference?) is still black. I’ve tried switching on the lights, wireframe etc. I do see the following information in the console output:


DesktopAssetManager created.
Camera created (W: 320, H: 320)
Loading obejct: Cube
Loading of constraints not yet implemented for version 2.5x !
Importing mesh.
Reading texture from file!
Loading material.
Loaded material definition: Phong Lighting
Materials name: {0}
Child (Cube1) attached to this node (Cube)
Cube: (0.0, 0.0, -0.0)--> null
Child (Cube) attached to this node (tudor-house.blend)
Child (tudor-house.blend) attached to this node (Root Node)
Uniform g_CameraPosition is not declared in shader.
Uniform g_WorldMatrix is not declared in shader.
Uniform m_UseVertexColor is not declared in shader.
Uniform m_UseMaterialColors is not declared in shader.
Uniform m_Minnaert is not declared in shader.
Uniform m_WardIso is not declared in shader.
Component hidden

What else can I tell you? I updated to the latest nightly build (yesterday), so not sure if there are issues here.
Please can somebody help me because I'm falling at the first hurdle here!

For what it's worth, you can upload the blender file HERE. It's from Blender 2.58, but I have been trying 2.57 files with no success either!

Thanks
Richard

Well if the house is black when you import it its no wonder its still black when you want to view it in the SceneComposer… How did you assign the texture? Can you see it in blenders “game mode”?

You can post your problem to @Kaelthas (the blender plugin developper) to: http://hub.jmonkeyengine.org/groups/import-assets/forum/topic/blender-loader-feedback/

1 Like
normen said:
Well if the house is black when you import it its no wonder its still black when you want to view it in the SceneComposer.. How did you assign the texture? Can you see it in blenders "game mode"?

Thanks Normen, but wouldn't I at least see it in wireframe mode? I assigned an unwrapped texture to it in Blender, Mapping to UV on the Textures panel and ensuring "Face Textures" was checked on the Materials panel. Indeed, I see there's a texture referenced on the image I've attached, which gave me hope. I agree that perhaps this is a setting somewhere, but I have tried the obvious ones IMO so it's a bit odd to me.

And how do I get "Game Mode" going on 2.5 !? I have tried a render, and that looks fine in terms of visible texture.

Help !

Richard

Game mode is only for blender engine. I would suggest you to import only mesh (from blender to JMP). Then make a Lighting material in JMP and assign textures to it.



Also, I would suggest you to use blender 2.57, as 2.58 is in development.

I saw your model. Everything looks fine. Just import the mesh and make a new Lighting Material in JMP.

Thanks Mifth… How do I import mesh only? Right now, I can’t import any blend file.



I am now moving back to 2.57b but still having the same issues. If I could just at least “see” the mesh in some form that would be great. Absolutely nothing appears on the Asset Pack after import. The log messages I saw (Uniform_XXX not declared …), are they relevant?



Thanks (and sorry for being such a dumb-ass)



Richard

Just convert your blend file to j3o and you will get your model (mesh).

There are 2 ways:

1 - Through import button

2 - (in JMP) right click at your blend file, then select “convert to j3o”



Then just assign a new material to your j3o model.



But if the blender converter does not work, so you should tell @Kaelthas at: http://hub.jmonkeyengine.org/groups/import-assets/forum/topic/blender-loader-feedback/