Eclipse Europa irritating OutOfMemory

Well… the title says it pretty well. I am extremely irritated at Eclipse Europa under Linux x86_64. The reason: I cannot build jME without first hitting an OutOfMemory error (heap space of the VM).

I have tried calling eclipse with

eclipse -vmargs -XX:MaxPermSize=1024m -Xms128m -Xmx1024m

and many other variations and numbers. I have also tried editing the eclipse.ini file to match these arguments to no avail. The point is that I recently updated to OpenSuSE 10.3 (x86_64) and this is not working anymore…

I would like an answer to this, but I realize there might be none… I am happy just to rant a little bit if nobody has any brilliant ideas on how to make this work.

This is my startup string on win32 –

C:eclipse3.3eclipse.exe -vm "C:Program FilesJavajdk1.6.0_03jrebinjavaw" -vmargs -Xmx500m -XX:MaxPermSize=128m

You'll probably have to double  -XX:MaxPermSize=128m  to  -XX:MaxPermSize=256m  because the runtime takes twice as much memory for referencess; they (references) go from 32 bits to 64 bits, 8 bytes instead of 4

NetBeans? :wink:

that is weird…im using europa as well, and it works fine…and im using default ini file, only changed the vm params

Yeah, it is weird, I did not have any problem with SuSE 10.2… I neglected to mention that I am using the YaST repository Packman to install Eclipse, instead of downloading it directly from Eclipse… Maybe this is it, but it should not.

Regarding NetBeans, even though I used it for many years, I have came to like Eclipse more and more recently. (EXCEPT FOR THE ST|_|PID MEMORY ERRORS).  :x

Oh, well, I think talking about this is therapeutic… I think I just hate everything that does not support x86_64 completely…

I would say, that Eclipse 64bit is still "experimental"

Here i can only find Red Hat Enterprise Linux 4.0 update 2, x86-64, GTK: Eclipse Project Release Notes 3.3

IntelliJ  Idea :wink:

monkeyman said:

C:eclipse3.3eclipse.exe -vm "C:Program FilesJavajdk1.6.0_03jrebinjavaw" -vmargs -Xmx500m -XX:MaxPermSize=128m

Well, as I said, I have been using very different setups, and as you can see in the first post, I even had -XX:MaxPermSize=1024m, and still had the memory error... what I will do is simply downgrade to a 32-bit JVM and Eclipse...

What happened to the good old days where Eclipse startup was just a JAR and not a binary? *sigh*  :|
What happened to the good old days where Eclipse startup was just a JAR and not a binary?

Nothing is stopping you from using the good old eclipse from a jar!  }:-@