Eclipse JME3 not running TestLineParticles

Hi again,

I got JME3 installed into eclipse 3.5 (galileo) along with subclipse (and subversion) according to your handy video onto my MacBook Pro (Nvidia 8600), JSE 6 (64bit) and it all seemed to compile jolly like on the vid.

It appears to be using JVM 1.5.0 (MacOS X default)

However, when i try and run TestLineParticles I get no window :(… and a bunch of this (red) in the console:

Feb 19, 2011 6:34:25 AM start

INFO: Application started.

Feb 19, 2011 6:34:25 AM com.jme.system.PropertiesGameSettings

INFO: PropertiesGameSettings created

Feb 19, 2011 6:34:25 AM com.jme.system.PropertiesGameSettings load

WARNING: Could not load properties. Creating a new one.

2011-02-19 06:34:25.668 java[4947:80f] [Java CocoaComponent compatibility mode]: Enabled

2011-02-19 06:34:25.669 java[4947:80f] [Java CocoaComponent compatibility mode]: Setting timeout for SWT to 0.100000

2011-02-19 06:34:26.871 java[4947:14503] *** -[NSConditionLock unlock]: lock (<NSConditionLock: 0x18cea0> ‘(null)’) unlocked when not locked

2011-02-19 06:34:26.872 java[4947:14503] *** Break on _NSLockError() to debug.

(and a few more repeats of the last 2 lines)

i'm a n00b so any advice will help :)
perhaps i have a dud library... wasn't sure if i should eat cocoa or chew carbon

PS I also tried it with JSE 5 32 bit but same same


Ok i just worked out how to use the debugger...
then it exploded and killed Eclipse when I tried to get back the package window.
... I'm going to stop drinking coffee now!

First of all, you’re using jME2.

Second, it seems you’re using SWT, and that has some compatibility issue with Mac.

I followed the video instructions for installing JME3 into eclipse using subversion from this repository: If this is actually jME2 then what’s the path to jME3?

As the instructions were for Windows, I wasn’t sure if I should use Cocoa or Carbon

The test demo selector window imports the awt stuff and i’m building from svn so…

How do I remove SWT from the build?


Theres instructions on how to install jME3 on the first wiki page, how did you find the old information?

Hi normen,

there is a youtube instructional video link on this page:

thanks for the new reference - I know it did say to read the wiki as i’m definitely don’t have uber java coder skillz.

I just thought the video was click easy…

me bad…