Effects are missing with SDK

Is this normal?

I am going over the demos and am currently trying the “HelloEffects” tutorial.

However, it is telling me that every asset I am trying to load does not exist:



[java]com.jme3.asset.AssetNotFoundException: Effects/Explosion/flame.png (Flipped) (Mipmaped)

at com.jme3.asset.DesktopAssetManager.loadAsset(DesktopAssetManager.java:239)

at com.jme3.asset.DesktopAssetManager.loadTexture(DesktopAssetManager.java:293)

at com.jme3.asset.DesktopAssetManager.loadTexture(DesktopAssetManager.java:312)

at com.jme3.asset.DesktopAssetManager.loadTexture(DesktopAssetManager.java:324)

at jme3test.helloworld.HelloEffects.simpleInitApp(HelloEffects.java:25)

at com.jme3.app.SimpleApplication.initialize(SimpleApplication.java:230)

at com.jme3.system.lwjgl.LwjglAbstractDisplay.initInThread(LwjglAbstractDisplay.java:129)

at com.jme3.system.lwjgl.LwjglAbstractDisplay.run(LwjglAbstractDisplay.java:205)

at java.lang.Thread.run(Thread.java:722)



Mar 17, 2012 8:48:50 PM com.jme3.renderer.lwjgl.LwjglRenderer cleanup

INFO: Deleting objects and invalidating state

Mar 17, 2012 8:48:51 PM com.jme3.input.lwjgl.LwjglMouseInput destroy

INFO: Mouse destroyed.

Mar 17, 2012 8:48:51 PM com.jme3.input.lwjgl.LwjglKeyInput destroy

INFO: Keyboard destroyed.

Mar 17, 2012 8:48:51 PM com.jme3.system.lwjgl.LwjglAbstractDisplay deinitInThread

INFO: Display destroyed.[/java]



I just did a fresh install on the SDK v3 Beta on a Windows XP. Any help appreciated.

I haven’t done these tuts in ages, but make sure it’s spelled right. Flame != flame

Hi,



I changed it to Flame.png and it did not help.

It is a Texture, don’t those come with the SDK?



Where are they located so I can check and see?

Works fine on my side.



How do you run it? You typed the whole thing?

I copied and pasted using the right packages and what not, and ran it.

That’s all. :3

Just create a new JmeTests project, obviously theres no test data in a default project… Oh, and read the manual as well as the tutorials (also on how to put the test data in a default project)