Enabled gamma correction, then everything goes darker!?!

I use only the guinode and Unshaded.j3md
I’ve enabled gamma correction, and everything looks darker… shouldn’t it have to look brighter instead?

Graphics Capabilities

FrameBuffer
FrameBufferMRT
FrameBufferMultisample
OpenGL20
OpenGL21
OpenGL30
OpenGL31
GLSL100
GLSL110
GLSL120
GLSL130
GLSL140
VertexTextureFetch
TextureArray
FloatTexture
FloatColorBuffer
FloatDepthBuffer
PackedFloatTexture
SharedExponentTexture
PackedFloatColorBuffer
NonPowerOfTwoTextures
MeshInstancing
VertexBufferArray
Multisample
PackedDepthStencilBuffer
Srgb
FrameBufferBlit
TextureCompressionS3TC
TextureFilterAnisotropic
DepthTexture
IntegerIndexBuffer
SeamlessCubemap

…and on top of that, gamma correction also hangs the application on a certain scene when I use the rootnode :expressionless:

You need to adjust everything for gamma correction - textures, lights etc.

Apparently, gamma correction works as intended ONLY if I use 32bit color depth. Probably a driver issue. :frowning:

Full screen+32bit: OK :+1:
Full screen+16bit: crazy artefacts and scaling :-1: :chimpanzee_mad:
Windowed+24bit: darker :-1:
Windowed+16bit: darker :-1:

Strange… But I always used 32 bit color depth, both in windowed and full screen mode.
I don’t know how gamma correction is implemented in JME 3.1, I made it on my own on shader level so I assume that other depth modes will look ok too.

Textures shouldn’t need to be adjusted but any hard-coded colors you have mat.setColor(“Color”…) type stuff will need to be converted. There are some methods on ColorRGBA to do this.

It sounds like that’s not really your issue but someone said that textures will need to be adjusted but they should be fine.

Works for any settings for me…
Gamma correction uses opengl hardware gamma correction, it’s not implemented in the shaders.