Error JMonkeyPlatform

Hi guys,

I’ve been trying to run a project from a friend of mine for a while now, but I can’t get it working. We both have JMonkey Alpha-3 with all the updates installed.

When I load the project, there appear exclamation marks in front of some of the packages of the project. In those packages I then find some methods with the error ‘cannot find symbol’. I get this error for example with the method getViewPort().

Now if I try to run the code i get the following error:

WARNING: Cannot locate resource: Common/MatDefs/Terrain/TerrainLighting.j3md

16-feb-2011 15:24:42 handleError

SEVERE: Uncaught exception thrown in Thread[LWJGL Renderer Thread,5,main]

java.lang.NullPointerException: Material definition cannot be null

at com.jme3.material.Material.(

at com.jme3.material.Material.(

at mygame.Level.Level.(

at mygame.Main.simpleInitApp(


at com.jme3.system.lwjgl.LwjglAbstractDisplay.initInThread(



I’ve tried a lot of different things with libraries and stuff, but I’m at a loss. It must have to do something with the libraries I’d say but I feel like I tried everything with that already. I hope someone here can help me out, because I really wanna start working on our project.

It seems your project is pretty broken, do you use svn and maybe forgot to resolve some update issues at some point? Then it might happen that you dont have a valid project.xml file anymore but only two versions of it with the conflicting lines. Create a new BasicGame project and compare the projects settings and files in the nbproject folder.

I’m pretty new to all this so I don’t know what you mean with svn. What do i have to compare in the nbproject folder? Both projects have the same files in the nbproject folder except for an extra lwjglapplet-impl in the folder of my friends project.

Maybe forgot to add that my friend can run the code just fine.

If your library settings are the same as a BasicGame project, try reinstalling and updating jMP, there might be something wrong with your libraries. Before you might want to try creating a new project and copying the code and assets over there and see if it works. Use Ctrl-C and Ctrl-V in the project Source and Assets nodes for that.

I’m having similar problems right now. I reinstalled JMP and it doesnt have the (Rigid/Character) control classes anymore. Have they moved in newer revisions? Cause if so, that’s strange I havent noticed before (I updated everything).

On another topic:

After reinstallation I still havent got the basicgame option for new project. I havent deleted my settings directory, but Im guessing that cant be it.

EDIT: It seems more things are missing:


some optionfunctions for the toonfilter


terrain adjustheight

and alot more judging from a glance at jmetests

I installed JMP on my old Pentium 4 Windows xp and it hangs on loading of the sceneviewer. However the basicgame option was available.

I also installed JMP in virtualbox on Ubuntu and the basicgame option was as well avaiable. I havent checked out if the dependencies were working, cause the mouse integration failed at some point.

How can I clear JMP entirely with all its registers and settingsfolders from my harddrive so I can have a 100% pure install? Itll probably be working again then.

I tried reinstalling netbeans and had no luck either (on Corei3 Windows 7, initial source of problem).

On windows you can best remove it using the uninstaller. Apart from that theres “.jmonkeyplatform” folders in the usual windows locations (AppData/Roaming/ and User/name/ or whatever it is in the current windows version) that store the settings, the one that contains a “dev” folder is the one that contains the permanent settings.

Okay, I’ll try to remove those and see if that helps. Thing was, the uninstaller was broken so I had to remove it manually.

So removing the Appdata/Roaming/ jmonkeyplatform folder restored the basicgame feature, but it still has compile issues:

40 errors

C:UsersKajosjMonkeyProjectsGlobalCommandnbprojectbuild-impl.xml:525: The following error occurred while executing this line:

C:UsersKajosjMonkeyProjectsGlobalCommandnbprojectbuild-impl.xml:259: Compile failed; see the compiler error output for details.

I used the standard basicgame and my original build-impl.xml and both gave the same errors and linenumbers.

EDIT: However JMEtests is now running fine which suggests the problem lies in the project. I tried copying the files over to a new project but then the new project would have the same errors as well.

Well, did you “see the error output for details”? :slight_smile:

omg, where can i find it?

Further up in the log

Oh, it just says its missing the classes I mentioned earlier.

Ah damnit…! I see CharacterControl has been renamed to PsysicsCharacterNode and being placed under Nodes.

Itll probably be the same for the other errors…

Strange I havent found these changes in my previous setup but well…

Thanks for your time.

No, PhysicsCharacterNode is the old and CharacterControl is the new version, you didnt update jMP to the nightly version, check the Manual (press F1 button) on how to do that.

Oops, thanks for noticing that :smiley:

It still doesnt properly export to Windows exe and applet. It hangs at data.jar loading (in the applet).

For the exe, run it from command line and see the error output, for the applet enable the java console in your browser and see the error output.

It was a problem with one of the textures being named .JPG instead of .jpg.

Yeah, those can be a bitch ^^ Classpath is case sensitive, windows filesystem is not…

hi, im also new at this.

i have read beginners tutorial and intermediate and it helped me in some thing but i got a problem now.<br /> when i use a basic game proyect and i copy some part of the code that is in the testproyect, the textures and materials dont appear and my app gets stock.<br /> ive tried to find the assets of the testproyect but i cant find them and also i`ve tried to find the Common folder or something like that but i cant find it.

Can someone help me?

Sorry for my english im from Cali,Colombia