Error windows on start of jMP

After one of the last few updates I’m getting 2 error windows at the start of jMP.

The first is:

Error opening OpenGL window!

Your graphics card needs to support at least OpenGL 2.0,

if this is the case, etc…

Error: java.lang.UnsatisfiedLinkError: H:UserDany.jmonkeyplatformbulletjme.dll: Can’t load IA 32-bit.dll on a AMD 64-bit platform.

In other words, please include a 64-bit DLL for bulletjme.dll.

The second error window says:

Your graphics card needs to support OpenGL 2.0, etc etc.

Error: java.lang.NullPointerException.

I suspect that second popup to be caused by the first.

Yes you’re right. I fixed the first bug in SVN, wait until an update is pushed for jMP and then it will be fixed :slight_smile:

Another addition in the update, Mac/Linux users get a more stable SceneViewer!

Most excellent.

I could do without usually, but it seems the SceneViewer is dependent on that dll and because of that I don’t get nifty XML previews. :confused:


As I wanted to check if there were any updates for jME I clicked on “Check Graphics Capabilities” instead. :confused: Do I need to underline that jMP crashed? hehe

Since the platform still works except for the SceneViewer, it might be a good idea to check for failures or whatever before launching the “Check Graphics Capabilities”… Just saying. :slight_smile:

Also, just noted this:

May 4, 2011 11:14:51 PM com.jme3.system.Natives extractNativeLib

WARNING: Cannot locate native library: windows/bulletjme.dll

Just wait for the update … it should fix that one too :wink:


I’ll just shut up now. :wink:

Got the fix for the problem but I still get

“Cannot locate native library: windows/bulletjme64.dll”

at start of jMP and also when I run/debug a project.

When I look into: H:UsersDanyDocumentsjMonkeyProjectsjME3_Alpha4enginelibbulletjarcontentnativewindows, that file is indeed not there. Only bulletjme.dll is. It’s also missing in the jar file as expected.

I’m not using bullet, not now anyway, so I can’t say if it’s breaking anything.

That one is just a warning. The bigger issue is what happens on 32 bit Windows, it will crash completely because the 32 bit dll has a dependency on some mingw dlls. I tried telling that to normen but he wouldn’t listen :x

Ah. Those poor x86 users.

Yeah. It’s just a warning. Posted it so you guys would know (even if you probably knew already).

I had this issue on windows 7 64 bits