Error with MidpointHeightMap

I'm using the current binary version of jME and finding I can't persuade it to behave when I ask it to create a midpoint height map. When I run this code (which worked before I downloaded a newer version of jME and I believe comes straight out of one of the tutorials):

 MidPointHeightMap mph=new MidPointHeightMap(64,1.5f);
    TerrainBlock tb=new TerrainBlock("midpoint block",mph.getSize(),
                                        new Vector3f(1,.11f,1),
                                        mph.getHeightMap(),
                                        new Vector3f(0,-25,0),
                                        false);

   TextureState ts=display.getRenderer().createTextureState();
    ts.setTexture( TextureManager.loadTexture(dirt, Texture.MM_LINEAR,Texture.FM_LINEAR) );
    tb.setRenderState(ts);
    tb.setModelBound(new BoundingBox());
    tb.updateModelBound();
    rootNode.attachChild(tb);


I get this:


INFO: Created Heightmap using Mid Point
15-Oct-2006 23:59:41 com.jme.scene.Node attachChild
INFO: Child (midpoint block) attached to this node (rootNode)
java.lang.NoSuchMethodError: org.lwjgl.opengl.GL11.glVertexPointer(IIII)V
        at com.jme.renderer.lwjgl.LWJGLRenderer.predrawGeometry(Unknown Source)
        at com.jme.renderer.lwjgl.LWJGLRenderer.draw(Unknown Source)
        at com.jme.scene.TriMesh.draw(Unknown Source)
        at com.jme.scene.lod.ClodMesh.draw(Unknown Source)
        at com.jme.scene.Spatial.onDraw(Unknown Source)
        at com.jme.scene.Node.draw(Unknown Source)
        at com.jme.scene.Spatial.onDraw(Unknown Source)
        at com.jme.renderer.lwjgl.LWJGLRenderer.draw(Unknown Source)
        at com.jme.app.SimpleGame.render(Unknown Source)
        at com.jme.app.BaseGame.start(Unknown Source)
        at jmetest.Main.main(Main.java:49)


I'm kind of regretting downloading the 0.10 binaries at the moment cos they seem to break everything that worked before and I'm not smart enough yet that I'm benefitting from whatever it is the latest point has added to the world. It's tricky cos I'm sort of looking for something quite reliable to start building my game against but any time I need any kind of help I'll need a current version...

Do you have a more recent version of lwjgl? I think that's your problem - version mismatch between that and JME.

I thought I had the latest version of that as well but god knows what Netbeans has done with the paths on my project, I guess it could have cached an old one somewhere.



Thanks.

Definitely the latest version of LWJGL ( I was already running that ) and definitely all the current Jar files in my lib directory and still the problem persists.



All guidance welcome.

This…

java.lang.NoSuchMethodError: org.lwjgl.opengl.GL11.glVertexPointer


...means you definitely have a version mismatch somewhere.  Please note we may not use the latest version of lwjgl from their site.  jME uses the lwjgl provided in cvs under /lib which at this time is either 1.0b2 or a custom blend... I don't really recall off the top of my head.

Never mind. I have given in and I'm trying to get Netbeans to work with the latest version out of CVS…

… and thanks to the fabulous Wiki entry it's working properly now.



Job's a good 'un :slight_smile:

I was having the same org.lwjgl.opengl.GL11.glVertexPointer(IIII)V error instantiating any object that implements AbstractHeightMap with the 0.10 release on Mac OS X in Eclipse when I found this post.



I tried connecting to the CVS server, but the CVS server is behaving erratically (it fails refreshing the tree after partial results, always at a different place).



Anyway, I fixed the issue by downloading the nightly build.



Also, the flag rush tutorial series is seems to have one minor incompatibility with the 0.10 release specifically in:


timer = Timer.getTimer();


needs to be

timer = Timer.getTimer(properties.getRenderer());


in the 0.10 release, but not in the most recent nightly build.

Anyway, thanks to all the developers on JME. I think it is great.