Exception access violation in com.jme3.bullet.collision.shapes.HullCollisionShap

Hey guys,

Just wondering if any of you encountered this access violation crash lately:

A fatal error has been detected by the Java Runtime Environment:

EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x000000000272f4a6, pid=5344, tid=4040

JRE version: 7.0_11-b21

Java VM: Java HotSpot™ 64-Bit Server VM (23.6-b04 mixed mode windows-amd64 compressed oops)

Problematic frame:

J com.jme3.bullet.collision.shapes.HullCollisionShape.getPoints(Lcom/jme3/scene/Mesh;)[F

Thanks in advance for any info!


How many vertices has your hull?

@EmpirePhoenix: 3640 verts and 1210 triangles. I used the same model before with no problems…

what is “lately”, what is “before”? what version of the engine do you use? the binaries for bullet are not official, somebody compiled them and they are not checked, native bullet generally is still in alpha.

@normen: I just tried with the last stable and last nightly version of jme3 with same results

Well I use a mass of hullshapes in bullet, so I can definitly say, that they are working.

Are you sure your mesh is valid? eg error in indices? Does a normal box shape work for example?

1 Like

I use a lot of them and it works also without problems.
@EmpirePhoenix: thanks for pointing me in the right direction: I was unloading geometries faster than the physics control was destroyed. I think I fixed it.