Exception in Game Loop

Hey Guys,



I'm on the way trying to setup JME for the first time, i think it's nearly finished but by trying to run Tests following Error appears i don't know how to fix this.



SCHWERWIEGEND: Exception in game loop

java.lang.UnsatisfiedLinkError: /Users/XXX/Documents/GD/jme/lib/liblwjgl.jnilib:  no suitable image found.  Did find:  /Users/XXX/Documents/GD/jme/lib/liblwjgl.jnilib: no matching architecture in universal wrapper

at java.lang.ClassLoader$NativeLibrary.load(Native Method)

at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1861)

at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1778)

at java.lang.Runtime.loadLibrary0(Runtime.java:823)

at java.lang.System.loadLibrary(System.java:1045)

at org.lwjgl.Sys$1.run(Sys.java:75)

at java.security.AccessController.doPrivileged(Native Method)

at org.lwjgl.Sys.doLoadLibrary(Sys.java:68)

at org.lwjgl.Sys.loadLibrary(Sys.java:84)

at org.lwjgl.Sys.<clinit>(Sys.java:101)

at org.lwjgl.opengl.Display.<clinit>(Display.java:111)

at com.jme.system.lwjgl.LWJGLPropertiesDialog$ModesRetriever.run(LWJGLPropertiesDialog.java:669)

at com.jme.app.AbstractGame.getAttributes(AbstractGame.java:219)

at com.jme.app.BaseGame.start(BaseGame.java:62)

at jmetest.TutorialGuide.HelloWorld.main(HelloWorld.java:51)





At this time i'm running:

Mac OS X

Eclipse 3.5.2

JVM 1.6.0





Additional i used this Tutorial to Setup JME:

http://jmonkeyengine.com/wiki/doku.php/setting_up_eclipse_to_build_jme



If u need some more informations its no problem to add later…





Best regards,

soxxing



//sorry for my bad english ^^

IMHO seems that you have setted the wrong native for lwlgl, there are 2 version for mac if i'm not wrong

lesto said:

IMHO seems that you have setted the wrong native for lwlgl, there are 2 version for mac if i'm not wrong

No, theres only one binary for mac, thats the beauty of universal binaries. Nevertheless it seems like you should update the lwjgl libraries to a current version, there might be issues with the version that is bundled with jme 2.0.1 on 64bit machines. The latest versions from jme svn or from http://www.lwjgl.org should work.