Failed to choose openGL version

i use the method



to set which version of OpenGL to use. But that did not work, when i run my application it still shows “信息: OpenGL Version: 4.2.0”.

i tried AppSettings.LWJGL_OPENGL1,AppSettings.LWJGL_OPENGL3,AppSettings.LWJGL_OPENGL_ANY and the results are all the same.My notebook only has a core graphics card of HD3000.As we know,it can suppot OpenGL 2.0 at most.And my application crashes everytime with the error:

A fatal error has been detected by the Java Runtime Environment:


EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x4dd50420, pid=5220, tid=6028

i use the latest verion of jme3 and just update my card driver. One of my mate can run the application correctly.His notebook is the same with mine.The only difference is his Windows is 64bit and mine is 32bit.

Can anybody tells me how to choose a lower version of OpenGL and how to aviod the crash problem.

Best wishes.


You do this before the start yes?

if so youa re already choosing the opengl2 wich should be right for your card.

i use the jme3 to paint on a canvas and i do that befor startCanvas(); i think it should choosing opengl2 for me too.In fact ,no matter which version of opengl i choose ,it still shows me “信息: OpenGL Version: 4.2.0″.What confused me is although i use a card only support opengl4.1, it tells me i am using 4.2 and everything goes well. I am wondering if the log in control platform shows the right info.

Regardless of what you set opengl version to, it will use the highest available version supported by the driver. That setting only changes the feature set that jME3 will use.

What happens when the setSamples call is removed?

the same error happens when i remove the setSamples,i tried to change my PC to a 64bit Windows7 and it can run well,why does this happen,and when i change my OS back ,it carshes again.

This will work:




thats the same he posted in first post.

is it a dual gpu notebook? maybee jme runs on the internal card