Failed to convert j3m files

when i transform the obj file to j3o, some exception occur with saying “Unknown statement in MTL! tf”. and the j3m file then to be empty.As result,s

ome effect such as translucent can not appear.What even worse is when i run the jme application with these empty j3m files ,sometimes the JVM crashes, the log shows that “EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x009fcf52, pid=4752, tid=4440”. This happens in PC with core graphics HD3000 sometimes,but never in my NVIDIA gt520 ,i do not know the real reason and feel so helpless.I think this is related to the failed transformation of j3m.I need a reliable way to run my application in any graphics card or even without a card.After all, the HD3000 only supports opengl2.0 and many computers armed with it. My boss is very angry on my poor performance, I am estimated to be unemployed if no one help me .I am facing the injury that i can not afford.Just crying “HELP!!!”.

First of all, go here: and download the latest driver for your HD3000. Second of all, make sure you’re using a recent version of jME3, preferably stable (update your plugins in jMP). This should fix the ACCESS_VIOLATION issue, if not, then you will need to provide more info.

For the J3M issue, tell us how you are getting a J3M from an OBJ file because I didn’t realize we had such a function.

@Momoko_Fan said:
For the J3M issue, tell us how you are getting a J3M from an OBJ file because I didn't realize we had such a function.

Its a function in the SDK.

Thanks men,I update my SDK to the latest version as your suggestion.I am happy to see that all my models transform correctly form obj to j3o and j3m. Unfortunately, when i run my application with the jme3 engine packaged in 2012-06-01,my new models seem strange for their shadows change to be dark and thick.That makes my scene very terrible.But when I run the same application in jme3 engine packaged in 2012-03-10,this problem disappears.I do not know if I have something wrong or this is just a BUG of the jme3.Hope for your help and thanks.

Picture of the wrong shadow as shown below:

So you are using PSSM shadows? Is this still on the Intel card?

yes ,that is PSSM and on a nvidia GT520m card.