Fatal Exception Fresh JME/Android Project

For a semester project I am tasked (with three others) to create a 3D-app for the Android. I have extensive OpenGL C++ experience but unfortunately my teammates have decided to work in Java, and with their only being two short months I have decided to use jMonkey as opposed to creating a renderer myself in Java, which I am not the most comfortable in. Plus none of us have any mobile development experience.

So with that information out of the way, here comes the error. I have the most up-to-date Android SDK (r19) with the JME SDK + the Android plugin (both downloaded today, May 24). I can get the sample program (the one generated when creating a new JME project) compiled and running, but immediately hit the following error:


(rotated for easier reading)

A copy of the log from the first error to the end:


With my zero Android and JME experience I unfortunately do not know how to approach whatever the issue may be. I greatly appreciate any help and will be glad to provide additional information if necessary.

OS: Windows 7

Android SDK: r19

JME SDK: 3.0 beta

JDK: 1.7

JRE: 7

The simulator doesn’t support jme, use a real phone connected via USB.

Ah I thought that may be it but heard that the emulator could support OpenGL ES 2+ now. Thanks for the quick reply.

@ssell said:
Ah I thought that may be it but heard that the emulator could support OpenGL ES 2+ now.

Yeah, not quite.. We're on it.. Some initial tests worked but it might require some adaptions or just mature a bit, it doesn't really report everything jme needs to know about the specs but we could check if its the emulator and just ignore that.. But then there were some screen clearing issues.. Well.. at least it starts to get improved ^^
1 Like

SVN version now supports emulator with GPU acceleration

1 Like

@ssell: Have you tried it again ? I’m curious if it works now.

I’m going to give it a shot too when I have time.