[Fixed]Wierd build (cache?) problem


I was just about to do a test release but in the middle of a build I realised something was wrong. I cancelled the build, removed a library and added a different one…then went to build again.


C:ZS CurrentClientsHeroDexClientnbprojectassets-impl.xml:5: A zip file cannot include itself

BUILD FAILED (total time: 0 seconds)


Now I just get that every time I try and build. I’ve tried removing and adding the libraries, I manually wiped the contents of the dist folder. Nothing changes it. The line in the file is:

[xml] <jar jarfile="${build.dir}/${assets.jar.name}" excludes="${assets.excludes}" basedir="${assets.folder.name}" compress="${assets.compress}"/>


I then thought maybe it’s a problem in the cache so I went to:

C:UsersTim.jme3 - but that just contained a folder called natives…

C:UsersTim.jmonkeyplatform - but that just contained a folder called asset packs (which is empty)

C:UsersTim.jmonkeyplatform-installer - but that just seems to have installed stuff

C:UsersTim.netbeans - but that just contains 7.0 and 7.1 which are netbeans versions not sdk versions.

So where is the actual cache files stored? Or is it something else causing the error?



Did you remove the assets folder from the “run” libraries tab?

1 Like

I did accidentally delete assets from the libraries, but I then put it back.

I just looked and it was in compile not run, I tried removing it and adding it back in run but it didn’t change the results.

Run contained:

Classpath for Compiling Sources

Compiled Sources

Folder Icon with blank next to it

Folder Icon with assets next to it.

I looked at my test project and that didn’t have the blank so I deleted both the blank line and assets, hit ok, went back into libraries->run - hit add JAR/Folder, selected assets, hit open then ok. The assets folder re-appeared in the libraries list again but clean and build still fails with the same error.

So whats your assets / asset jar settings, why is it trying to compress the file into itself?

1 Like

If I go into build->assets it says:

JAR Name: assets.jar

excludes: /*.j3odata,/.mesh.xml,**/.skeleton.xml,/*.scene,/.material,**/.obj,/*.mtl,/*.blend

folder location: blank

Compress is ticked.

I put assets into folder location and suddenly everything is working again. It looks like my accidentally deleting it from the library also blanked it there. Thanks a lot for the help!