Fragment shader failed to compile

Hi all!,

when i run TestWalkingChar sample the following error shows up

Apr 19, 2011 7:43:01 AM com.jme3.renderer.lwjgl.LwjglRenderer updateShaderSourceData
WARNING: Bad compile of:
#define HAS_GLOWMAP 1
#extension GL_ARB_texture_multisample : enable
uniform int m_NumSamples;
uniform int m_NumSamplesDepth;
SEVERE Application 7:43:01 AM Uncaught exception thrown in Thread[LWJGL Renderer Thread,5,main]
com.jme3.renderer.RendererException: compile error in:ShaderSource[name=Common/MatDefs/Post/bloomExtract15.frag, defines, type=Fragment] error:Fragment shader failed to compile with the following errors:
ERROR: 0:20: error(#155) Internal error wrong operand type built in unary operator function. Type: in sampler2DMS
ERROR: error(#273) 1 compilation errors. No code generated
anyone has had this problem ?
i'm using
Product Version: jMonkeyPlatform Alpha-4
Java: 1.6.0_24; Java HotSpot(TM) Server VM 19.1-b02
System: Windows XP version 5.1 running on x86; Cp1252; en_US (jmonkeyplatform)
Userdir: C:Documents and SettingscarlosApplication Data.jmonkeyplatformdev
The testcinematic sample programs (from TestChooser.exe) don't run , either .
I investigated and I think that has to do with the filters,
if i comment the filters functions the programs, run
private void setupFilter() {
FilterPostProcessor fpp = new FilterPostProcessor(assetManager);
BloomFilter bloom = new BloomFilter(BloomFilter.GlowMode.Objects);
I reported this error in the jmonkeyengine issues, but so far the state has not changed, remain as new.
as anyone had this problem, I think that somehow has to do with my graphics card,
I uploaded the latest drivers but nothing has happened, still the same....
My card settings is: (sorry the long post ...)
Renderer: ATI Mobility Radeon HD 3430 Vendor: ATI Technologies Inc. Memory: 512 MB Version: 3.2.9606 Forward-Compatible Context Shading language version: 1.50 Max texture size: 8192 x 8192 Max texture coordinates: 0 Max vertex texture image

thank you for you reply .

I had already done the update of the video card,

I try again, i.e, i download all drivers for my grafics card (radeon), and i re-installed everything.

my computer is a hp-laptop , 6730s , also, i download all the drivers from hp and installed everything,but still the same …

maybe, my card don’t support this feature.

Please update your graphics card drivers. This error has been fixed in the newer version.

You can download new drivers for your card here:

1 Like