Fullscreen vs. Not Fullscreen - Rendering issues

Hi all

This is a very strange one. I packaged up my current build to see if I could webstart it so my mate could see how it was coming along. He ran it on his machine just fine, except he was getting some strange lines across his screen. I therefore tried the webstart build on my other PC and I managed to get the same problem, but only at a certain resolution and only fullscreen. Here’s some examples:

800 x 600, 16 bpp, 75 hz, NOT fullscreen:

800 x 600, 16 bpp, 75 hz, fullscreen:

Has anyone seen anything like this before ?



Hmm… no.  Except that the bpp might not be 16 in windowed mode if the desktop is 24 or 32…  Does twiddling with the display setings do anything?

16bpp might lower the Z-Buffer to 16 bpp… are you doing some kind of 2+ pass splatting for making that terrain?

Yes, llama, that's exactly how I do the terrain. One pass for the terrain's main textures, and then one pass for the detail (paths, etc) using an alpha map. Can you explain a little more about how the zbuffer could be effecting this. Thanks much.


Just an adendum:

I have been into my ATI catalyst control center and ticked the box "force 24-bit zbuffer depth" and everything works fine.

So, my question is, is there anything I can do programmatically with the zbufferstate to ensure that it is not necessary for people to force a higher zbuffer depth ?



Well, when jME creates a window, the z-buffer depth is a parameter.  Look inside SimpleGame (and perhaps the classes it extends) to see where it does that.

But maybe you want to know what's going on too (Z-Fighting), read about that in Mojo's blog:


As for fixing it (other than using a deeper z-buffer), put the near plane of your camera less close (or the far plane further away, but that helps less), or maybe use an offset for your second pass.

Thanks llama, most helpful.

The summary given in Mojo's blog is great. I understand a lot better now. I will play around with the near and far planes of my camera, and report back here incase this is useful to anyone else.

One other thing:

... or maybe use an offset for your second pass.

Not sure what you mean by this I'm afraid.


Check this thread: http://www.jmonkeyengine.com/jmeforum/index.php?topic=5758

Thanks guys. I shall check that out tonight and see what can be done.

Your help is much appreciated !