Generating LODs in the SDK

Hi All
My game is progressing petty well… But as I’m starting load more models and with increased details to my scene, My FPS is dropping as the number of triangles increase… So I though ill see what i can do with LOD and i read the article bellow

My models are manually created so i thought i would use the “Generating LODs in the SDK” process. I followed the UI and defined 3 levels for a object at .25, .5 and .75 and pressed finish. But when i then check the UI to verify my levels i can only see 1 level, interestingly there was one level present before i started but number in that one level changes after the process (before 0 - 7034 / after 0 - 22456)
Is there something I’m doing wrong,? is The UI in the SDK just not showing the other levels?

The article also talks about “Activate the LOD Control”
is that something i need to do? or does that happen automatically when using the SDK?

At the moment its not really reducing the number of triangle enough… is there a more aggressive reduction strategy?

Many thanks

That sounds weird, can you post a screen shot of the model in wireframe mode please.

Once lod is generated, you need to add a LodControl to the model so that the lod are switched according to the distance of the object from the camera.

Also, you may think your problem is the number of triangles, but it may be the number of object, actually. You may look into batching some of the objects of your scene. See this doc

sure the screen shot is here

the Lod Level has just one option which says 0 - 22824 triangles

then i go through the process like this

there are no errors but there is still only one option.

Cool i will add the LodControl… And dig into object optimisation…
thanks for your help!!

Seems that the lod generator lose its way with this model. You shouldn’t have as much triangle as the number of vertice in the first lod.Something is wrong.
could you upload the model so I see what’s going on?


thanks heaps for your help

Im trying to make a age of empires style RTS in a 3d version with much less units (about 25x2)… I have merged all the structures. And they are rendering pretty well. However whenever i have other characters in the view port the FPS drops from 30 to 10. And i cant seem to merge them without loosing animations. Should i try to use BatchNode? should i try to batch all the characters together?

I’m not home for now. I’ll check your model in couple of days.