Going to Try Ludum Dare (Theme "You are the Monster") with the SDK alpha. I will post all my questions here

First Question.
Use case I want to add a path on a terrain using the SDK Paint Texture:
Painting Terrain in the SDK does not seem to work
I created a new Basic Project
I added the jme3-test-data lib
I created a new scene
I added a terrain : flat
I edit the terrain
I can edit the height of the terrain : works :smile:
I add a new texture (Pond.jpg and Pond_normal.jpg)
I select the new texture so that it has focus
I click on the spray can (Text says “Erase Texture”…Is that correct?)
I am not able to paint the texture. I tried with button , button + shift, button+ctrl nothing seems to work.
How do I paint the path?



Second Question: How do I get access to the AnimControl in code?

If I open up a Bender File in the SDK and convert it to a j3o file. In the SceneExplorer Window it has a hierarchy of

if spatial is the dilo_animated.j3o loaded
This code returns null
AnimControl control = spatial.getControl(AnimControl.class);

How do get access to the AnimControl in the hierachy above? Do i need to loop through all the children until I find one?


I ended up doing hierachy search

private AnimControl getAnimControl(Spatial spatial){
   AnimControl control = spatial.getControl(AnimControl.class);
       return control;
   }else {
       if(spatial instanceof Node){
           Node node = (Node) spatial;
           for(Spatial child : node.getChildren()){
               AnimControl childControl = getAnimControl(child);
                   return childControl;
   return null;

Hi, yes we also used a hierarchy search before we had a solid asset structure.

Now we make the assumption that every model has its animControl and skeletonControl at the correct place.

Never worked with the Terrain Editor, so I cannot say anything about that.