handleError on using new imported model

Heya, I’m probably missing something obvious. But here goes. I have been using a placeholder model for a project I’ve been working on. Yesterday I tried to change over to newer models and I got this error.

Dec 06, 2012 6:10:40 PM com.jme3.app.Application handleError

SEVERE: Uncaught exception thrown in Thread[LWJGL Renderer Thread,5,main]


at com.jme3.scene.BatchNode.updateSubBatch(BatchNode.java:108)

at com.jme3.scene.Geometry.updateWorldTransforms(Geometry.java:292)

at com.jme3.scene.Spatial.updateGeometricState(Spatial.java:684)

at com.jme3.scene.BatchNode.updateGeometricState(BatchNode.java:83)

at com.jme3.scene.Node.updateGeometricState(Node.java:177)

at com.jme3.app.SimpleApplication.update(SimpleApplication.java:258)

at com.jme3.system.lwjgl.LwjglAbstractDisplay.runLoop(LwjglAbstractDisplay.java:149)

at com.jme3.system.lwjgl.LwjglDisplay.runLoop(LwjglDisplay.java:185)

at com.jme3.system.lwjgl.LwjglAbstractDisplay.run(LwjglAbstractDisplay.java:223)

at java.lang.Thread.run(Thread.java:722)

What confuses me is that the only thing I changed, was the path for the model. This is the line that messes it all up,

[java]Spatial hex0 = assetManager.loadModel(“Models/hexfade_02/hexfade_02.j3o”);[/java]

I tried re-importing the model, I checked my batching code, I tried importing new models, and I tried just naming things differently. Nothing works except for the original line of code.

[java]Spatial hex0 = assetManager.loadModel(“Models/HexPiece_05/HexPiece_05.j3o”);[/java]

The only difference between the original model and the new one is that the new one uses a gradient material. But this can’t be the problem, because I tried doing it without that difference and it still won’t work.

Can someone tell me what I’m missing? Thanks!

I have spent the last week fighting with this very same issue, I was able to import a previous version of my model from blender, and it worked fine until i decided to update my model, this is the closest thing i have found to this issue. Were you able to find a solution?

Thank you so much for your time.

Do or did you use nightly at some point to convert the models? Cause that is prone to cause issues as the changes in the file format are not always made consistent immediately.

Sorry about not getting back to this quickly. I moved onto another set of mechanics. thanks normen, that fixed part of the issue (the models still won’t show up even though I have lighting). gievo, you should give that solution a shot (if you haven’t already), best of luck.