Hello SimpleApplication Tutorial not showing a blue box

So I basically copy/pasted this tutorial: https://wiki.jmonkeyengine.org/legacy/doku.php/jme3:beginner:hello_simpleapplication

I hit compile, chose resolution on the splash screen, hit “ok” and I get a black screen showing debugging information. No blue box.

No errors in the console either. I’m using the Maven setup described here:https://wiki.jmonkeyengine.org/legacy/doku.php/jme3_maven?s[]=maven

Any pointers on what to do next appreciated, I’m running a 64-bit Windows 7 with 8 gigs of memory and an ATi Radeon HD 4870 x2 with the latest drivers, so I’m pretty sure I should be able to render a simple cube. A similar program written using jPCT ( http://www.jpct.net/ ) works fine so I guess we can rule out drivers, java version and lwjgl as potential sources of the error.

Kind Regards,

Mikkel Løkke.

I had the exact same issue with latest ATI drivers on win7 64, (for 5970 but i guess it’s the same)

The fact that something similar works with another engine, doesn’t rule out any source of error…

Try to add a second cube to the scene, if it renders then it’s the same issue than mine.

From what i could figure out, the first object added to the scene never renders.

I had to roll back to previous drivers version.

@Momoko_Fan, this issue is a bit annoying, we should try to corner out what’s wrong, maybe we do something that does not follow the specs and ATI drivers stopped to be tolerant…or it’s a driver’s bug and maybe we could report the case to ATI.

Hi nehon,

That “worked” great, Here is the code that “works”:[java] @Override

public void simpleInitApp() {

Box b = new Box(Vector3f.ZERO, 1, 1, 1); // create cube shape at the origin

Box b2 = new Box(Vector3f.ZERO, 1, 1, 1); // create cube shape at the origin

geom = new Geometry(“Box”, b); // create cube geometry from the shape

geom2 = new Geometry(“Box2”, b2); // create cube geometry from the shape

Material mat = new Material(assetManager, “Common/MatDefs/Misc/Unshaded.j3md”); // create a simple material

mat.setColor(“Color”, ColorRGBA.Blue); // set color of material to blue

geom.setMaterial(mat); // set the cube’s material

geom2.setMaterial(mat); // set the cube’s material

rootNode.attachChild(geom); // make the cube appear in the scene

rootNode.attachChild(geom2); // make the cube appear in the scene


[/java] This will show 1 cube (geom2), also note that it is necessary to create both new shapes as well as new geometry. I’m not proficient enough in jME3 to comprehend why, but if you create geom and geom2 from the same Box instance, neither of them will show.

Could you tell me which driver versions worked for you? the AMD site is broken ATM and I’m not really in the mood for a round of trial and error. The reason I upgraded in the first place was because the FAQ for Spiral Knights suggested it, so I figured it would apply here too.

I might try this new driver on my ATI later and see what happens

i am running across the same thing. added a new post then found this. Any update on this?