Hostile Sector Public Alpha

Hey all.

I’ve been quiet lately, much due to work, but recently i picked up the pace with Hostile Sector development.

I’ve come to a point where i think it’s time to let the public have a go at it, so from now on the server will be up.

The initial release is 0.5 and here are the release notes:

Hope to see you on the server.




kewl! I’ll check that tonight ;)!!

Hey, cool! Gonna check this out right when I’m back on a computer. :smiley:

Hey Rickard

I’ve just tried the game.

This looks pretty slick!! Graphics are terrific, the maps are very detailed and the modeling/texture work is awesome.

Also your UI looks perfect, and fits very well with the tone of the game.

All looks very professional.

I was a bit lost at first though, i didn’t really knew where to go in the menus.

I found my way though and started the tutorial mission with the alpha team.

Brilliant thing to have made a tutorial, with check points and all.

The camera movements are very nice now (i remember them a bit unpredictable in the last open test). now they are precise and easy to grasp.

Then…i don’t know if that’s a bug or something i didn’t get, but i didn’t manage to shoot the targets in the tutorial.

Each time i come close to them and shoot them (the percentage is some thing like 68% - 98%) the squad plays some sort of shooting animation but it looks like it’s interrupted…and nothing happens. A menu invite me to retry until the percentage hit 0%.

Ending the turn reset my action points but, i can’t shoot the targets…

Sometimes I have a “john Doe reload” inscription on the squad but nothing comes out of the guns.

I managed to shoot things in the last open test so i guess it’s a bug or something.

Since i wasn’t able to shoot things I just took a walk in the map, and the result is very pleasing. One thing though, the tutorial tells you that info are displayed when you hover over a tile but , it does not seem to work, I seldom have the info poped, but it was even on a left or right click.

When you move there is a small delay between the moment you enter the command and the moment the squad actually moves. It’s not a big deal when you know it, but the first times you just think the command has not succeed.

This is very promising, I’m looking forward your progress.

Keep up the good work!

Hey, and thanks for the feedback!

I noticed the bug in the tutorial too. It’s fixed on the server (it was due to borked json. I need to write a better parser).

The info pops up after a couple of seconds. It can however be quite annoying as it also shows when you have the menu open. I might need to do something else.

The delay you notice is the response time to the server. So it’s pretty much inevitable, i’m afraid. I can however work with UI to present it better.

I hope to get mp up and running again this weekend.

Again, thanks!

@rickard said:
I noticed the bug in the tutorial too. It's fixed on the server (it was due to borked json. I need to write a better parser).

...may not be useful to you... but it may and I posted a ref to it earlier somewhere else... :)

Probably the most straight-forward and spec compliant JSON classes you will find...

It doesn't do any fancy serialization of objects... but will go straight from JSON to Maps and Lists of primitives and back again. I use it for Mythruna's user database.
1 Like

Awesome. I will have a look at it.


@rickard said:
Awesome. I will have a look at it.

Let me know if you spot anything. I'm trying to make it as perfect as possible. :)

Nearby, there are also some super light weight expression language classes that can be used to easily grab things out with dot notation... just depends on your usage as to what you might need.

Just uploaded a new version. Here’s the changelist:

“Play Now” button introduced again, making for easier game creation. With it comes also… multiplayer!

The matchmaker is currently run once a minute, and player count is rather low, so don’t expect too much of it yet. However, you can easily start a solo mission through the same interface, if it turns out you’re alone.

A number of hotfixes were done on the server during the week:

Fixed bug where Swamp wouldn’t change side properly

Fixed bug where firing at Fire-at-triggers didn’t work (Thus making Tutorial impossible to finish)

Fixed bug where solo missions were deleted too soon.

Fixed bug where soldiers with no weapon (if the storage is full) wouldn’t not show up when recruited.

The deployment of the build seemd to have failed earlier. It’s now been updated.

Just made a server side fix, where solo missions launched through the Play Now interface wouldn’t load correctly.

Have you started tipping off game magazines & bloggers about the alpha? Also, I’m like a broken record about this but I can’t recommend enough for free marketing. They get tons of traffic and do a really good job of promoting worthy game entries. Also the more high quality games jMonkeyEngine is associated with on IndieDB, the better it makes us look :wink:

Thanks for the tip!

I’ve deliberately started off pretty slow on the marketing side. Would like to get a few builds up and tried before going broad, and sort out any serious issues (if any left). Although indiedb might be a good place to find early adopters.

Once again, a new build has been deployed.

Not so many prominent features this week, mostly ui and stability fixes, but the “John Doe” bug has finally been resolved, so names should be much more interesting now. Unfortunately, those soldiers already affected will keep their names.

I’ve also integrated the latest jme, so now any exceptions will be displayed in a dialog. Feel free to email me, or write about it in the forum, so they can be sorted.



Desktop test!


I’ve uploaded a desktop version of Hostile Sector. It’d be great if some of you could try it out and see how it works.

One warning, though. If you switch to “fullscreen mode” in the options menu, there’s no way of getting back to window mode without quitting first, since the display selector is shown behind the application. I’m working on that…



Edit: Oh, and you still need to create an account at, if you haven’t already.


hey Rickard, i didn’t achieve to connect.

i tried reseting my password on the web site, login with email address or username… (btw you can’t type ‘@’ with an azerty keyboard for some reason i had to switch to qwerty)

There is no error but nothing happen when I hit login.

Strange… Anyone else having problems logging in?

Maybe i should add some error messages :stuck_out_tongue:

I’ve also (thanks to JMP magic) created a mac and linux bundle. I have no idea whether they work, so if someone could test them and give me a verdict, i’d be grateful:

Not so sure it will work on Linux. The launcher file contains:

java -Djava.library.path=“c:/projects/lwjgl/;C:/projects/lwjgl/windows_natives” -XX:MaxDirectMemorySize=512M -jar Hostile Sector.jar

the C: is obviously not that hot, also, it is a good idea to not use spaces in the name :confused:

Yeah, the command line options are taken over to the app, you should remove/change them @rickard