HottBJ wrong animation

Hi all,

I have had the following problem for a few days now: I try to apply an armature on my own model, following the (great) HottBJ tutorial. I have my armature, I import the model as a .3ds, make sure the scale, rotation and position of the armature and model are exactly the same. Then apply Armature modifier to the mesh (no enveloppe). Then apply bone heat (works the first time). Finally, I create a "Walk" animation, in addition to the "staticPose", both still looks fine in blender. Then I select both armature and mesh (without applying the armature Modifier to the mesh) and export them as jme-xml.

Now here's what I've got when activating the "staticPose" (which is a normal result to me):

But suddenly on the "Walk" animation, the mesh is all distorted:

I've tried to 'downsize' the "walk" animation to the point where it's only 3 frames where all bones have the exact same position as the "staticPose" (so it doesn't really constitue an animation), the mesh is still distorted …

Any idea as of what common mistake I could have made, or how to check if my blender export is correct (I have this problem with the HottBJ model viewer where the java swing window is just totally blank, so I can't really use it)



Here some things you should always consider if using hottbj (I hate the name :smiley: ):

  • Before starting with the armature use ctrl-a (in objectmode) in order to apply rotation and scale to the mesh.
  • when starting with the armature select the mesh, use shift-s with cursor to selection (or similar). That ensures that you really have the same position for the armature as the model
  • now you can create the armature
  • before you parent the armature to the model you should set all bone-rolls to 0 (actually I don't know  if this is necessary. I do it every time)

    Hmm,… there might be more options I don't rember now. Maybe you want to send the file to me so I could have a look…

For the record, thanks to ttrocha, the problem was that I hide my superbone for the different actions so I needed to unhide the superbone and save each frame with the super bone included