How do i get jme working in eclipse?


i have tried installing jme in eclipse but for one reason or the other i cant get it to work.

i am using:

jdk1.6.0_03  with jdk compliance set to 6.0 (also tried 5.0)

Eclipse 3.3.0

i used the following tutorial

in step 10 i try to run the TestTeapot

but i get the following error

Oct 19, 2007 12:02:14 AM start

INFO: Application started.

Oct 19, 2007 12:02:14 AM com.jme.system.PropertiesIO <init>

INFO: PropertiesIO created

Oct 19, 2007 12:02:14 AM com.jme.system.PropertiesIO load

WARNING: Could not load properties. Creating a new one.

Oct 19, 2007 12:02:14 AM class jmetest.renderer.TestTeapot start()

SEVERE: Exception in game loop

java.lang.UnsatisfiedLinkError: no lwjgl in java.library.path

at java.lang.ClassLoader.loadLibrary(

at java.lang.Runtime.loadLibrary0(

at java.lang.System.loadLibrary(

at org.lwjgl.Sys$

at Method)

at org.lwjgl.Sys.doLoadLibrary(

at org.lwjgl.Sys.loadLibrary(

at org.lwjgl.Sys.<clinit>(

at org.lwjgl.opengl.Display.<clinit>(

at com.jme.system.lwjgl.LWJGLPropertiesDialog.<init>(



at jmetest.renderer.TestTeapot.main(

Oct 19, 2007 12:02:14 AM cleanup

INFO: Cleaning up resources.

Oct 19, 2007 12:02:14 AM com.jme.system.lwjgl.LWJGLDisplaySystem <init>

INFO: LWJGL Display System created.

Oct 19, 2007 12:02:14 AM start

INFO: Application ending.

i already tried to find the awnser on the forum so i can awnser the folliwing quiestions:

i went to run as/ open run dialog and put the command "-Djava.library.path=./lib" in the VM arguments

(i also tried to put the dll's in windows/system32 and use -Djava.library.path=c:windowssystem32 and tried the static path to the lib)

I did this as well

Then Expand lwjgl.jar → Native Library Location → Edit → Workspace… → expand jME → select lib → OK → OK → Finish.

and as last i did the previous to all the jars i had to import.

And everything is a checkout from the cvs so i asume all the jars and dll's are the right versions.

so for now i am out of ideas any help is welcome

thanks in advantage.



Besides lwjgl.jar there are a couple of other jars that need natives libs setup. Also sometime eclipse gets buggy with the build, try project -> clean.

Thanks for the reply

Unfortunatly i tried both already

i set the libary path for all the jars just in case

and i used clean after every new thing i tried.



Doublecheck you are pointing to the lwjgl.jar in the right place. Also there might be remote possibility it downloaded with errors. Try donwloading everything again and setting it up in a different project.

When you check out from CVS make sure to use HEAD branch.

I tried instakling the repositorue checkout on my pc and after that i tried to install it on my

laptop both had no effect.

And i am pointing to the lwjgl.jar in the lib folder in the build path (so the one downloaded from the repository). this should be the right one yes ?

I checked the out  head/jme

but again nothing worked not on my desktop and not on my laptop.

anyway thanks for your help.

Differnt try differnt problems.

i now tried to download the nighly build an dinclude the jars in a user libary

now i only get an error

first a popup sais could not find main will exit program and the following error is in the console

java.lang.NoClassDefFoundError: and

Exception in thread "main"

i am trying to run the HelloWorld sample (it does have a main and i also told eclipse to use that class as main)

i tried the following 3 commands just

-Djava.library.path=C:Documents and SettingsaterlamiaDesktopjME(2)

-Djava.library.path=C:Documents and SettingsaterlamiaDesktopjME(2)lib

-Djava.library.path=C:Documents and SettingsaterlamiaDesktopjME(2)liblwjgl.dll

All dont work while when i remove that command it will find the main just have the lwjgl not found error.

Maybe this is easier to solve then the last one ? (stilli would like to know the solution to the other problem as well)




I dont know what i did but now it works (the nightly build) now i can start exploring jme .