How to fix indentations?

As per topic, I upgraded from 3.0 to 3.2.1 stable and suddenly my ability to reformat code disappeared. Long time ago I somehow set it so when I hit ctrl+i the code indents were set to default, but now my keybinding is gone.
I tried searching for keyword indent in the keybinding options but none of the options work and “indent” ruined the little indents I had!

I want to use 4 spaces as indent, class members indent, method bodies indent, etc - and when I go into
options -> Editor -> Formatting
the preview looks exactly like it should yet the code formatting is complete trainwreck

EDIT:
I think I’ve found it, but under different name - it’s source -> format but I’m not sure if it doesn’t do more than just fix indents. Can someone please confirm if format only touches indents?

Iv never seen this before, so (presumedly) it must be a configuration file on your side. Can you maybe rename the configuration files and check? Revert them back if it’s a no go.

which files should I rename? The ones in jmonkeyplatform/config/Modules or does it have some other place with config?

Did you export the 3.0 settings for the SDK and import them into the 3.2 version?

No, I had some issues upgrading and ended up deleting everything and making a fresh install (or at least I deleted entire content of jmonkeyplatform directory

Do you have a backup of your 3.0?

I did zip everything before deleting so yes, I do.

But seems like the source->format does what I want, question is if it does more than just indenting?

I use Eclipse, not Netbeans, but generally “format” features pretty up lots of things beyond formatting. They often do tend to make the code more readable however, so unless it’s that big of an issue to you I’d lean in favor of letting it do its thing. Format settings are often customizable too.

I think I’ll do so and if I see anything that bugs me a lot, then I’ll try to solve it. Only thing I can see is it ignores commented section but that’s something I can live with it. I did a quick test and I see I can put braces where I want in the settings and formatting helper won’t mess with them.

I think this solves my problem, thanks for help!