How to install JavaFX on JMonkeyPlatform

I have been using the Netbeans IDE to develop JavaFX apps for about 7 months. It was easy to use.



About 3 months ago, I wanted to try Jme3, so I installed JMonkeyPlaftform.Alpha-3 Since then I’ve been trying to install JavaFX as a plugin inside JMonkeyPlaform, but it never worked.



Today I decided to install JMonkeyPlatform Alpha-4 and try JavaFX again. It failed with the same message. (Please see the bottom).

I still have the original JavaFX SDK installed. I tried to install the JavaFX-Netbeans bundle from scratch. But the installation starts and said all required components have been installed and quit. So my question is:



I always though JMonkeyPlatform is really Netbeans. Is certain feature disabled? Or is certain plugin incompatible with JavaFX?

If no feature was disabled, then how did a new JavaFX-Netbeans installation can report current Netbeans installation already has all the required components?



Does anyone also develop JavaFX, I don’t mind installing two separate copies of Netbeans as long as I can work with JavaFX on one, and Jme3 on the other.





Thanks for reading this long message.





=============== ERROR MESSAGE: ====================



Some plugins require plugin Editor Library to be installed.



The plugin Editor Library is requested in version >= 2.1 (release version 2) but only 3.8.0.13.8 (of release version different from 2) was found.

The following plugins are affected: JavaFX Composer JavaFX Profiler



Some plugins require plugin Java Common Project API to be installed.

The plugin Java Common Project API is requested in implementation version 201007282301.

The following plugin is affected: JavaFX Profiler



Some plugins require plugin Parsing API to be installed.

The plugin Parsing API is requested in implementation version 4.

The following plugins are affected: JavaFX Composer JavaFX Profiler



Some plugins not installed to avoid potential installation problems.

You know that JavaFX script is deprecated right? Anyway the plugins dont work because jMP is too current for these. The plugin expect editor v2 and jMP uses editor v3. You will have to wait until NetBeans 7.0 (if the JavaFX stuff get ported at all)

I do know that JavaFX script is deprecated. My code base is the good old Java, JavaFX script was used at the user-interface level. I am ready to switch back to Java, I am actually looking forward to JavaFX 2.0.



Thanks for your explanation. I was just disappointed that I can’t have two installations of Netbeans 6.9, each with different sets of plugin. I guess they automatically share the same plugins.



I guess I’ll just have to wait for the new JavaFX.

Maybe you find compatible versions in the NetBeans 7.0 beta update centers… I dont know the urls tho…