How to make nifty stop responding to input

I have a screen made with nifty gui to change the controls for my game, but it acts strange when I try to press a key to configure it for an action, while that key also has an action in nifty. So, how can I temporarly disable nifty’s input, while still making it display the screen?

Many thanks in advance.

It’s been a while since I have used Nifty, so my suggestions depend on your answer to how Nifty handles input.

In Nifty, aren’t the individual control responsible for their own input handling? Or is it global and being delegated by JME’s input handling?

If the answer is Global, than the best you can do is set up a game state flag and check against this prior to delegating the input to Nifty.

I guess input handling would have to be this way, or this wouldn’t be a problem to begin with.

you can do it globally or each individual element.

You’ll find both examples in here: