How to set the parameters of the "heap space" of the SDK?

Greetings community , I need your help to avoid error, “directbuffermemory” when viewing scenes or large objects.
I have 8 GB of RAM, I would assign the “head space” about 5 or 6 GB maximum use.
What parameters should change because I’ve changed the 2 parameters showing there, but it is giving me error loading large objects.
not quite understand how you must configure.

A thank you in advance for your help.

[java]# ${HOME} will be replaced by user home directory according to platform
default_mac_userdir="${HOME}/Library/Application Support/${APPNAME}/3.0RC2"

options used by the launcher by default, can be overridden by explicit

command line switches

default_options="–branding jmonkeyplatform -J-Xms24m -J-Xmx512m -J-XX:PermSize=256m -J-XX:MaxDirectMemorySize=2048m"

for development purposes you may wish to append: -J-Dnetbeans.logger.console=true -J-ea

default location of JDK/JRE, can be overridden by using --jdkhome switch


clusters’ paths separated by path.separator (semicolon on Windows, colon on Unices)

[/java] :amused:

Well your current configuration tells it to use 512mb for heap space and 2gb for direct memory. As a simple test just set both to 6000mb and try if it works then, after that more intelligent values can be determined. (Note it might be that the vm wont start if setting them to high, since the operating system may veto this behaviour)

Also wich java version and wich operating system?

1 Like

You should setup the parameters in the VM Options of your projects run properties.

Go to Project Properties -> Run -> VM Options:

Set the maximum heap by writing:
-xmx6g or -xmx6144m

That should do it. This is a netbeans / java issue, not jME though.

1 Like

it works!
thank you for the help and your time … I match both values to 6000 and I can load heavy models, in project properties not work for me, but thank you very much alike.