HttpZipLocator giving blank assets

Hello everyone,

I am having problems with HttpZipLocator acting strangely when I try to load assets. It does locates the asset (which is a model) in the zip file, but it gives me a Spatial with 0 triangles, whereas the models contains about 17k triangles. The file is located on a distant computer on my local network, running a http server.

Here is how I registrer the locator and load the model:

[java]app.getAssetManager().registerLocator(“”, HttpZipLocator.class);

model = am.loadModel(“01.obj”);[/java]

and model.getTriangleCount() returns 0.

May be the zip file isn’t handled correctly? Are there unsupported compression methods?

Thanks a lot for your help :slight_smile:

Are you sure it works locally? Do you get any warnings or errors?

@normen said:
Are you sure it works locally? Do you get any warnings or errors?

It works fine if I use a ZipLocator and use a zip located on my computer, meaning that the zip file is handled correctly.
The server is OS is ubuntu but I don't think it as anything to do with it.
By the way I am using the last nightly update.

when I load the model locally, I get theses warnings (but the model is displayed correctly though):

15 mai 2012 17:51:28 com.jme3.scene.plugins.OBJLoader loadMtlLib
ATTENTION: Cannot locate deco1_tex.mtl for model Models/01.obj
15 mai 2012 17:51:29 com.jme3.scene.plugins.OBJLoader createGeometry
ATTENTION: OBJ mesh 01-geom-0 doesnt contain normals! It might not display correctly

I don't get theses when using HttpZipLocator, it looks like the model description is somehow ignored by the loader...

What software did you use to create the zip file? Any chance you can post a sample of a zip that doesn’t work here?

I tried on another server, and it worked fine… I guess the issue came from the server itself and not the HttpZipLocator, I don’t understand what…

Anyway the file was made by winrar on windows and works fine with ZipLocator. I also tried with a file made by the default archive manager on Ubuntu.

Thanks for taking time to answer me :slight_smile: