I am new to JME and i can't even compile an example

run:

30-Jul-2011 6:39:15 PM com.jme3.system.JmeSystem initialize

INFO: Running on jMonkey Engine 3 Alpha 0.6

30-Jul-2011 6:39:15 PM com.jme3.system.Natives extractNativeLibs

INFO: Extraction Directory #1: file:/C:/Program%20Files/jmonkeyplatform/jmonkeyplatform/libs/

30-Jul-2011 6:39:15 PM com.jme3.system.Natives extractNativeLibs

INFO: Extraction Directory #2: G:jbeanJavaApplication7

30-Jul-2011 6:39:15 PM com.jme3.system.Natives extractNativeLibs

INFO: Extraction Directory #3: G:jbeanJavaApplication7

30-Jul-2011 6:39:15 PM com.jme3.system.lwjgl.LwjglAbstractDisplay run

INFO: Using LWJGL 2.7.1

30-Jul-2011 6:39:16 PM com.jme3.system.lwjgl.LwjglDisplay createContext

INFO: Selected display mode: 320 x 200 x 16 @60Hz

30-Jul-2011 6:39:18 PM com.jme3.app.Application handleError

SEVERE: Failed to create display

org.lwjgl.LWJGLException: No support for WGL_ARB_multisample

at org.lwjgl.opengl.WindowsPeerInfo.nChoosePixelFormat(Native Method)

at org.lwjgl.opengl.WindowsPeerInfo.choosePixelFormat(WindowsPeerInfo.java:52)

at org.lwjgl.opengl.WindowsDisplay.createWindow(WindowsDisplay.java:185)

at org.lwjgl.opengl.Display.createWindow(Display.java:317)

at org.lwjgl.opengl.Display.create(Display.java:857)

at org.lwjgl.opengl.Display.create(Display.java:785)

at com.jme3.system.lwjgl.LwjglDisplay.createContext(LwjglDisplay.java:134)

at com.jme3.system.lwjgl.LwjglAbstractDisplay.initInThread(LwjglAbstractDisplay.java:100)

at com.jme3.system.lwjgl.LwjglAbstractDisplay.run(LwjglAbstractDisplay.java:206)

at java.lang.Thread.run(Thread.java:662)

30-Jul-2011 6:39:20 PM com.jme3.app.Application handleError

SEVERE: Uncaught exception thrown in Thread[LWJGL Renderer Thread,5,main]

java.lang.IllegalStateException: Cannot determine close requested state of uncreated window

at org.lwjgl.opengl.Display.isCloseRequested(Display.java:583)

at com.jme3.system.lwjgl.LwjglAbstractDisplay.run(LwjglAbstractDisplay.java:208)

at java.lang.Thread.run(Thread.java:662)

BUILD SUCCESSFUL (total time: 12 seconds)

this is my error… and i am using this example:



/*

  • To change this template, choose Tools | Templates
  • and open the template in the editor.

    /

    package javaapplication7;



    import com.jme3.app.SimpleApplication;

    import com.jme3.material.Material;

    import com.jme3.math.Vector3f;

    import com.jme3.scene.Geometry;

    import com.jme3.scene.shape.Box;

    import com.jme3.math.ColorRGBA;

    /
    * Sample 1 - how to get started with the most simple JME 3 application.
  • Display a blue 3D cube and view from all sides by
  • moving the mouse and pressing the WASD keys. */

    public class JavaApplication7 extends SimpleApplication {

    public static void main(String[] args){

    JavaApplication7 app = new JavaApplication7();

    app.start();

    }

    @Override

    public void simpleInitApp() {

    Box b = new Box(Vector3f.ZERO, 1, 1, 1);

    Geometry geom = new Geometry(“Box”, b);

    Material mat = new Material(assetManager, “Common/MatDefs/Misc/Unshaded.j3md”);

    mat.setColor(“Color”, ColorRGBA.Blue);

    geom.setMaterial(mat);

    rootNode.attachChild(geom);

    }

    }



    what do i need to do to fix it?? im new so talk with simple words…

Looks like your card either doesn’t support OpenGL2 or you dont have the latest drivers.

lol what does that mean?

get a better one :P, joke ^^, download latest drivers for GPU and see if that helps

No … what this means is that your card doesn’t have anti-aliasing.



In the settings selection screen, make sure anti-aliasing is set to “Disabled” and not “x2”/“x4” for example.