I am seemingly cursed

Except for webstart which was explained Iv’e had no luck. Also, quick start guide and that wasn’t a sufficient explanation either. If any of you could explain step by step exactly how to get jME to work on Mac OS X it would be greatly appreciated as would any help for that matter.

If it’s any help I am running OS 10.3.7 and I have xcode 1.1 (what I prefer) and BlueJ 2.0.1. I hope I am not out of line asking for this to be explained (it could be very difficult to explain). Thank you again for at least hearing me out.

Hey, no problem. How much have you tried going with Eclipse and using Eclipse’s built in cvs abilities? I’ve been able to get it running just dandy on 10.3.7 with Eclipse setup being the only task. Also, what kind of Mac do you have, especially video card, ram and processor?

Hardware Overview:

Machine Model: Power Mac G4

CPU Type: PowerPC G4 (2.1)

Number Of CPUs: 1

CPU Speed: 867 MHz

L2 Cache (per CPU): 256 KB

L3 Cache (per CPU): 2 MB

Memory: 768 MB

Bus Speed: 133 MHz

Boot ROM Version: 4.2.5f1

Serial Number: XB14216YKSK

Sales Order Number: M8360LL/A

ATA-4 Bus:


Capacity: 74.53 GB

Model: WDC WD800BB-00FJA0

Revision: 13.03G13

Serial Number: WD-WCAJ91334709

Removable Media: No

Detachable Drive: No

BSD Name: disk0

Protocol: ATA

Unit Number: 0

Socket Type: Internal

OS9 Drivers: Yes

GeForce2 MX:

Type: display

Bus: AGP

Display Type: LCD

Slot: SLOT-1

VRAM (Total): 32 MB

Vendor: nVIDIA (0x10de)

Device ID: 0x0110

Revision ID: 0x00b2

ROM Revision: 1055


Resolution: 1280 x 1024

Depth: 32-bit Color

Mirror: Off

Online: Yes

Main Display: Yes

I just tried eclipse and it had an error claiming that their is no such user as guest.

Ok, you should be able to do moderate jME development (obviously no shaders, etc.)

Eclipse cvs is complaining about guest because you can not use the guest account to log into dev.java.net (anymore?). You’ll need to go to https://jme.dev.java.net/ and register. You may even need to join the jme project there, but probably not. Once you have done that, you can use your java.net login name instead of guest.

perhaps it would be a good idea to change your getting started text. I spend quite a while figuring it out. (searched at forum

Alright, I have the CVS files downloaded into the eclipse project folder.

I did build it with the build.xml file and it says it was successful. I don’t know where to go from there.

"middy" wrote:
perhaps it would be a good idea to change your getting started text. I spend quite a while figuring it out. (searched at forum
Actually, just did some of that, I'm sure there's a few spots to change it on still though.

have you tried simply building the project in eclipse rather than attempting an ant build?

I’ve ran into a problem, it seems that buildtest.xml is corrupt. I cannot build what I need to run the test.

I thought that’s how you do it I’m not familiar with eclipse.

Eclipse is usually setup to autobuild by default, so chances are, you’re already built! :slight_smile: You can open one of the test files and in the menu click Run->Run As->Application.

The closest thing I could find was Run -> External Tools -> Run As -> Ant Build. It claims that the build is successfull but debug gives an error.

<terminated, exit value: 0> /path/to/system/java/files/

No window has appeared and the only two files in target are doc.zip and jme.jar don’t there need to be more?

Would I have better luck if I tried to emulate webstart?

What perspective are you using? If it is the Java perspective, and you current have one of the jmetest classes open and viewing, Run->Run As->Java Application will be available.