IDE Package bug (files don't show in package in project selector)

Hello all,

I went to check out the files within a package, to work with, and noticed they weren’t there.

I thought that maybe I didn’t copy them over from another project, so I tried to copy them over and am met the the error message “some files contain the same name, files will be renamed.”

I then exited and tried to figure out where they were, but I couldn’t find any option that was useful.

I then copied the files over, and all of the files_1 were opened, but none were still shown inside the package.

I closed all the files in the editor, and then closed my IDE.

I reopened my IDE and noticed the ‘+’ on the package, clicked it and nothing…

I then went to “files” opened the source and sure enough both sets of files are there…

So what’s going on? Is this JMonkey, or Netbeans? I’m confused as this has never happened before.

The only thing I can think of is that I copied the files from another project, but it definitely worked the last time I opened that package…

Weird… Any idea…? I could open the files from the “files” tab, but would be easier in the projects tab…

EDIT: Tried to copy to another package in the project and the same thing…

I Broke my IDE… :cry::cry::cry::cry::cry::cry::cry::cry::cry::cry:

What is the extension of those files?
Looks like the IDE dosn’t recognize them as project files.

They are just regular class/java files, made via the IDE.

NOW I did create this via NETBEANS IDE, instead of JMONKEY IDE

HOWEVER I did open the “Netbeans Project” inside “Jmonkey” and it opened fine.

When I try to “copy files over” it just doesn’t appear. It opens in the IDE, and I can edit them, but they aren’t in the project folder…

I don’t know why it would open fine in one project, but copying to another project yields invisible classes :frowning: ?

Thanks Nehon :slight_smile:

Just delete the project/folder and create an new one, fast and guaranteed solution.

not really because it didn’t go into 2 different packages. I can try a new package, and see if that changes it, but I don’t know.

If you create the project in regular netbeans then it won’t work properly in the JME SDK. That’s a given.

Just some of the classes. But why wouldn’t it work? The code should be the same regardless, right?

But maybe that’s due to what version of netbeans JME uses and that would fork off of the current ver of 7.4, or w/e? So project build and such?

The code itself is still code regardless though?

Sure, but I’m not sure what that has to do with how the IDE works with its project files.

Create a new project in the SDK. Import your sources. See that it works fine that way. Scratch your head about why the project files for one IDE won’t work with a different one and get on with your day. :slight_smile: